WordPress.org

Ready to get started?Download WordPress

Forums

Problems with install (3 posts)

  1. rubythomas
    Member
    Posted 2 years ago #

    Hello,

    I have download wordpress, updated all my DNS stuff 4 days ago so this should be transferred. Have put all wordpress files onto my FTP, but when I try to go to my domain address /wp-admin/install.php I keep getting a 404 error. this is how my code looks (I've changed user names passwords etc) is this how it should look?

    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'XXXX');

    /** MySQL database username */
    define('DB_USER', 'XXXX');

    /** MySQL database password */
    define('DB_PASSWORD', 'PASSWORD');

    /** MySQL hostname */
    define('DB_HOST', 'mysqXXX-XX.wcX.stabletransit.com');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define('AUTH_KEY', 'put your unique phrase here');
    define('SECURE_AUTH_KEY', 'put your unique phrase here');
    define('LOGGED_IN_KEY', 'put your unique phrase here');
    define('NONCE_KEY', 'put your unique phrase here');
    define('AUTH_SALT', 'put your unique phrase here');
    define('SECURE_AUTH_SALT', 'put your unique phrase here');
    define('LOGGED_IN_SALT', 'put your unique phrase here');
    define('NONCE_SALT', 'put your unique phrase here');

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
    * language support.
    */
    define('WPLANG', '');

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  2. Please learn to use pastebin.com for sharing large lines of code like that, it's easy and makes reading code much easier.

    That said, it's probably not your wp-config.php file that's the problem.

    but when I try to go to my domain address /wp-admin/install.php I keep getting a 404 error.

    Is WordPress in the root of your webserver or in /wordpress?

    - Check your URL. If the files are in /wordpress then try /wordpress/wp-admin/install.php.

    - Confirm that your DNS is correct and pointing to the correct IP address. Use either nsloookup or one of the many web based DNS lookup tools.

    - Confirm that the web server you are using is configured to use the directories you've setup WordPress in.

    If you don't have access or aren't sure, then a quick chat with your host provider should sort that out.

  3. Tim S
    Member
    Posted 2 years ago #

    Do you have a link we can look at? Can you provide us the url?

Topic Closed

This topic has been closed to new replies.

About this Topic