WordPress.org

Ready to get started?Download WordPress

Forums

problems with inside page links (8 posts)

  1. johnnyRing
    Member
    Posted 1 year ago #

    Hi,
    I've installed wp ms 3.5 for a multilingual site with multidomain option selected. I'm using multilingual press plugin for translating different pages, that works well enough.
    The problem is that for classifying my materials I've done a index page with many issues (titles), each of them is linked to another page that explain deeper the matter.
    The italian and french version of my site give me no problem, but english version is very orginal: when I link the title to the page the result is :
    "No Results Found

    The page you requested could not be found. Try refining your search, or use the navigation above to locate the post."
    If I look at the url I notice that every time the permalink is the correct url+%E2%80%8E
    I've set custom permalink /%category%/%postname%/%post_id%
    I've tried to change them but the problem has not gone away.
    I've not others plugins activated.
    I was thinking to use a redirect 301.
    Someone can drive me to the best, please?
    thanks a lot
    j.

  2. Does it work with non-pretty permalinks?

  3. johnnyRing
    Member
    Posted 1 year ago #

    Setting permalinks on default,that is http://en.namesite.eu/?p=123, the links drive to home page. French and italian version go as well.
    thanks for your help

    ps
    what if I update wordpress to 3.5.1 version?

  4. johnnyRing
    Member
    Posted 1 year ago #

    Just for giving all informations: the url that the link opens is not changed after I've set permalinks on default, that is correct url+%E2%80%8E/. In this case I have not "no result find" but the home page

  5. I think this has to do with a bad plugin or theme, honestly, or somethign custom in your .htaccess

    Nothing in WP proper adds anything like that.

  6. johnnyRing
    Member
    Posted 1 year ago #

    It may be multilingual press that gave some troubles, or the combination of that with wordpress multisite, then?
    Nothing particular in htaccess, except the canonical setting of multisite e.g.

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    more: some simple redirect 301 (multilingual press plugin didn't work for home pages).
    What would you do if you were me?
    thanks a lot

  7. I'd turn off Multilingual press and see if it fixes it. And then I'd go ask that developer what I was missing, and read all the help files to see if I could find it myself.

  8. johnnyRing
    Member
    Posted 1 year ago #

    Thank you :-)

Topic Closed

This topic has been closed to new replies.

About this Topic