WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problems with IE (11 posts)

  1. fabian.schmid
    Member
    Posted 1 year ago #

    Hello

    The theme I'm about to develop and customize on http://2013.fabians.ch displays quite strange in IE. Tested in IE8 and IE9 - they both display it differently. It should the way it does in FF and Chrome.

    I can't get what it is that smashes the layout. Can anyone find something?

    Thanks

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  3. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 1 year ago #

    It should the way it does in FF and Chrome.

    Unless you tiptoe around IE when building your website, this is not the case. Building websites to work in FF and Chrome means websites should break in IE.

  4. fabian.schmid
    Member
    Posted 1 year ago #

    Thank you WPyogi, I'm gonna validate and put a Doctype in there.

    Unless you tiptoe around IE when building your website, this is not the case. Building websites to work in FF and Chrome means websites should break in IE.

    There are always ways to make it look kinda okay in IE as well. That's all I need. But I can't find the elements or styles that cause the main trouble.

  5. fabian.schmid
    Member
    Posted 1 year ago #

    They don't have a doctype in twentyeleven and twentyten themes though. Why's that?

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Oh yes they do, don't know where you are looking but there is DEFINITELY a Doctype in every WP default theme!

    And for that matter, any theme in the WP repository is required to have a valid DOCTYPE.

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    And yours does have one, it's just that there is CSS code above it -- which is a problem and may well be causing the issues in IE. And yes, there certainly are ways to cope with IE - annoying but possible.

  8. fabian.schmid
    Member
    Posted 1 year ago #

    I'm sorry I was being blind and posting too quickly...long day. Thanks for your super-fast replies!

    There must be some plugin putting code above my doctype declaration. Though it was SEO Facebook but it apparently isn't. Gonna try with deactivating all of em..

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    No problem -- it just cracked me up :)! (It's a bit like saying the earth is flat -- LOL)

    Did you try to change the bottom margin on h2 tags - that's what the errant code is doing...

  10. fabian.schmid
    Member
    Posted 1 year ago #

    The earth is flat though, ain't it?! :O

    Yes I just changed them and set those styles with classes. Validation working now, thanks!

    And hell that is great. IE9 is now displaying everything as perfect as it can! As well is IE9 in compatibility mode for IE8. In IE7 mode there are some more imperfections however I guess I can fix that pretty soon.

    Shoulda thought of validation earlier, it's been too long since the last serious coding:)

    Thanks again, have a good evening (or whatever time it is where you are).

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    LOL -- morning in California, and the sun is shining after 4 days of total rain. You have a good one too!

Topic Closed

This topic has been closed to new replies.

About this Topic