WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Problems with htaccess permissions (6 posts)

  1. Meginoz
    Member
    Posted 1 year ago #

    After much difficulty getting W3 Total Cache working on a client's website at their own host, I set up a mirror of the site in a subdirectory of my own site, and I had everything running perfectly very quickly, using most of the auto-configure options in the plugin.

    Then I set up a new hosting account for them, on the same server as the test site, and used Backup Buddy to move the functioning test site across. Now I can't get the plugin to work correctly, as it keeps telling me there are problems with file ownership and permissions. I have manually entered the code for browser caching and page caching into the .htaccess file, but I still get the error message.

    The basic issue seems to be that it can't read / access the .htaccess file.

    Here is the full error messages it is giving me, with my comments in italics:

    W3 Total Cache Error: The plugin tried to edit, /.htaccess, but failed. Files and directories cannot be modified. Please review your file permissions. A common cause is .htaccess and /home/braveart/public_html/wp-content having different ownership or permissions.

    I have checked this and everything has the same, correct owner.

    File: /home/braveart/public_html/wp-config.php File permissions are 644 File owner: braveart:braveart

    File: /.htaccess File permissions are 0, however they should be 644. File owner: root:root

    I have checked this too, the file permissions are 644. The owner is braveart.

    Directory: /home/braveart/public_html/wp-content File owner: braveart:braveart
    Owner of current file: braveart:braveart
    The files and directories have different ownership, they should have the same ownership.
    The required directives for fancy permalinks could not be detected, please confirm they are available: Creating and editing

    Again, I have checked and the code is in the .htaccess file, and all my permalinks are working just fine.

    The following configuration changes are needed to ensure optimal performance:
    To enable Minify, add the following rules into the server configuration file (/home/braveart/public_html/wp-content/cache/minify/.htaccess) of the site .
    If permission allow this can be done automatically, by clicking here: .

    The following configuration changes are needed to ensure optimal performance:
    To enable Disk enhanced page caching, add the following rules into the server configuration file (/.htaccess) of the site above the WordPress directives .
    To enable Browser caching, add the following rules into the server configuration file (/.htaccess) of the site .

    I have tried uninstalling and reinstalling the plugin, but I still get the same messages.

    Any clue what's going on here? The two sites are running in exactly the same server environment.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Meginoz
    Member
    Posted 1 year ago #

    Update: I wiped everything and moved the site again manually. Some of the errors described above are gone, and file ownership problems are resolved.

    However, I still get these errors:

    Browser caching is not active. To enable it, add the following rules into the server configuration file (/.htaccess) of the site . Or if permission allow this can be done automatically, by clicking here: .

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    I tried the auto-install option, but then I get the following error:

    The browser cache rules could not be modified. Please create an empty file in /.htaccess and run chmod 777 /.htaccess to resolve this issue.

    However, it has actually written the code into the .htaccess file, it just seems to think it can't.

    This is on exactly the same server where I previously got everything working using the auto-install buttons. What on earth can be going on here????

  3. wpboys
    Member
    Posted 1 year ago #

    Go to install tab , and follow instructions there to manually make changes to .htaccess file. There You will find all the code to add in .htaccess file.

  4. Meginoz
    Member
    Posted 1 year ago #

    Thanks wpboys, but the code is in the .htaccess file, but the plugin thinks it isn't.

    I've also tried adding the code manually, but still get the same error. It's like it can't see what's in the .htaccess file - it can put the code in, but can't see that it's there.

    I'm actually in the process of reinstalling again. I think Backup Buddy may be the culprit, as I realised that although I was now transferring the site manually, I was working with copies of the site that I had tried to use Backup Buddy on, and I think it has left things behind that are affecting something. So now I'm going back to an older backup of the site from before I installed Backup Buddy, and seeing if it works that way.

  5. mbrsolution
    Member
    Posted 1 year ago #

    Hi @Meginoz, I am not sure if you have done this before when you deleted the plugin.

    Make sure that you totally remove every folder and file that is associated with the plugin and even removing the plugins lines from the .htaccess before you reinstall it again. Many that have done this here in the forum and have been successful.

    Kind regards

  6. wpboys
    Member
    Posted 1 year ago #

    Go to Miscellaneous section and uncheck Verify rewrite rules.
    even if you see the errors in the backend, it might be working just fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic