WordPress.org

Ready to get started?Download WordPress

Forums

Problems with functions.php after upgrading (3 posts)

  1. deguia
    Member
    Posted 7 years ago #

    I've posted this in another forum, and haven't had any luck. So I'm hoping posting it here will yield some helpful info.

    If anyone can help me with this, I would really appreciate it!

    I upgraded from WP v.2.0 to v.2.0.4 and since then, any theme I install that has a page for theme options, when clicked, I get a white screen that says simply:

    "Cannot load functions.php."

    I've checked the permissions and reinstalled the functions.php file. This happens on more than one theme so I'm hesitant to assume it's a theme programming error. These very same themes worked fine before the upgrade. To be sure, i've even downloaded the newest versions of the themes, installed and activated them, but to no avail.

    has anyone else run into this problem?

    Also, after the upgrade the Widgets plugin won't load either. It works fine and the already activated themes work fine, until I want to, you know, actually modify them or set up new ones. I've even gone so far as to ask a friend who uses WP to email me his functions.php file, replaced mine with his and it still won't work.

  2. MichaelH
    Member
    Posted 7 years ago #

    Not sure I can help but a couple of things to consider.

    Are your themes widgetized?

    Do the themes have functions.php files?

  3. deguia
    Member
    Posted 7 years ago #

    The themes are definitely widgitized. I'll check out the widgets having their own functions.php file... that didn't occur to me.

Topic Closed

This topic has been closed to new replies.

About this Topic