WordPress.org

Ready to get started?Download WordPress

Forums

WP Biographia
[resolved] Problems with Feedburner (17 posts)

  1. grouperteam
    Member
    Posted 1 year ago #

    Ciao i've installed your fantastic plugin but after my feeds doesnt works anymore and i have this kind of error
    error on line 100 at column 30: Input is not proper UTF-8, indicate encoding ! I checked and there is something wrong on the plugin text... do you have any issue to help me for resolve this problem? sorry for my english. Ciao Franco

    http://www.grouper.it

    http://wordpress.org/extend/plugins/wp-biographia/

  2. grouperteam
    Member
    Posted 1 year ago #

    thats the error in feedburner: line 114, column 205: XML parsing error: <unknown>:114:205: not well-formed (invalid token) [help]

    that's the line:

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your code may now have been permanently damaged/corrupted by the forum's parser. ]

    Personal trainer e massaggiatore sportivo</p><div class="wp-biographia-links"><small><a href="mailto:info@alessiorinelli.it" title="Send Alessio Rinelli Mail">Mail</a> | <a href="http://www.alessiorinelli.it" title="Alessio Rinelli On The Web">Web</a> | <a href="http://www.twitter.com/alessiorinelli" title="Alessio Rinelli On Twitter">Twitter</a> | <a href="http://www.facebook.com/rinelli.alessio" title="Alessio Rinelli On Facebook">Facebook</a> | <a href="http://www.grouper.it/author/rinelli/" title="More Posts By Alessio Rinelli">More Posts (1)</a></small></div></div><!-- WP Biographia v3.3.0 -->
  3. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ... you're absolutely right. There's a UTF-8 encoding error in your feed and it's somewhere in the HTML that WP Biographia emits.

    From plugging your site's feed into feedvalidator.org I get the error message XML parsing error: <unknown>:215:767: not well-formed (invalid token) which does show an encoding error.

    From looking at the feed's contents, I can see there's two sections of encoded data. One is in the URL for the user's avatar and one is in the obfuscated email address for the user.

    I'm inclined to think it's an issue caused by whatever plugin you're using to generate user avatars rather than in WP Biographia itself. The email address encoding is handled by the WordPress antispambot API call so unless your user has some very odd characters in their email address I think we can rule this out for now.

    What I'd recommend is that you configure WP Biographia not to output user avatars temporarily and then resubmit your feed URL, http://www.grouper.it/feed/ to feedvalidator.org and see if it validates cleanly. If it does then you'll need to look at what your avatar plugin is doing in more detail.

    Please take a look at the sticky post at the top of the WP Biographia forums and let me know what versions of WordPress and WP Biographia you're running as well as the name and download URL of the avatar plugin so I can try and replicate this.

    -Gary

  4. grouperteam
    Member
    Posted 1 year ago #

    Actually I tried your detail but still doesnt work... i really do not understand why..i tried to delete all the user avatar plug installed and also I took out the plag in your plugin config for the image user....but nothing....I still have the same error

    <?xml version="1.0" encoding="UTF-8"?>
    <rss version="2.0"
    xmlns:content="http://purl.org/rss/1.0/modules/content/"
    xmlns:wfw="http://wellformedweb.org/CommentAPI/"
    xmlns:dc="http://purl.org/dc/elements/1.1/"
    xmlns:atom="http://www.w3.org/2005/Atom"
    xmlns:sy="http://purl.org/rss/1.0/modules/syndication/"
    xmlns:slash="http://purl.org/rss/1.0/modules/slash/"
    >

    <channel>
    <title>Grouper Team</title>
    <atom:link href="http://www.grouper.it/feed/" rel="self" type="application/rss+xml" />
    <link>http://www.grouper.it</link>
    <description></description>
    <lastBuildDate>Wed, 07 Nov 2012 21:44:56 +0000</lastBuildDate>
    <language>it-IT</language>
    <sy:updatePeriod>hourly</sy:updatePeriod>
    <sy:updateFrequency>1</sy:updateFrequency>
    <generator>http://wordpress.org/?v=3.4.2</generator>

  5. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ... two things to mention here.

    Firstly, as one of the moderators added to your original post, unless you either click on the code button or use backticks to surround the feed XML, it renders as pretty much unreadable.

    Secondly, I've just checked your site's feed XML and it's still outputting the avatar HTML; I can see something like the following for each post in your feed ...

    <img src="http://www.grouper.it/wordpress/wp-content/plugins/user-avatar/user-avatar-pic.php?src=http://www.grouper.it/wordpress/wp-content/uploads/avatars/9/1352070534-bpfull.jpg&w=100&id=9&random=1352070534" alt="" class=" avatar avatar-100 photo user-9-avatar" width="100" height="100" />

    I'm assuming that the plugin you're using for avatars is the User Avatar plugin (http://wordpress.org/extend/plugins/user-avatar/).

    So try this ...

    1. From the Dashboard navigate to Plugins and click the Deactivate link underneath the description of your avatar plugin.

    2. Now navigate to Settings, WP Biographia. Click on the Content tab and ensure that the User's Image checkbox is not ticked. If it is, un-check it. Click on Save Content Settings.

    Then post back here. I can then go and re-check your feed's XML and we can take it from there.

    One other thing. While we're looking at this, it's vital to check the feed coming directly from your site and not the version from FeedBurner as that site may be caching your feed.

    -Gary

  6. grouperteam
    Member
    Posted 1 year ago #

    Ciao Gary I really appreciated your help, im quite new with wordpress so sorry for it.
    I've done right now the 2 things that you ask me. I deactivate alla the avatar user plugin and I took out the tick in the content\user image of WP biographia.

    Let me know if you find something different now.
    Thanks a lot in advance,

    Franco

  7. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not seeing this reflected in your feed. Are you running another plugin that's doing some caching? I can see the same avatar image tag in your feed, which tells me that either your avatar plugin is still running and configured in WP Biographia or that your feed is being cached and not being generated afresh each time I hit the http://www.grouper.it/feed/ URL.

    -Gary

  8. grouperteam
    Member
    Posted 1 year ago #

    Ciao Gary that's its really strange because in the original post http://www.grouper.it/acqua-dimagrire-con-beneficio-2/ there's no avatar as i deactivate it. I posted out some new article now, would you mind to check it?
    Thanks

  9. grouperteam
    Member
    Posted 1 year ago #

    in effect now is :
    <!-- WP Biographia v3.3.0 -->
    <div class="wp-biographia-text-no-pic"><h3>Alessio Rinelli</h3><p>Laurea in Scienze motorie e sport presso Università Statale di Milano. Personal trainer e massaggiatore sportivo. Presidente associazione Fitness e Benessere.</p><div class="wp-biographia-links"><small>Web | Twitter | Facebook | More Posts (1)</small></div></div><!-- WP Biographia v3.3.0 -->

  10. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    So I've found the source of your XML parsing errors. Something is inserting invalid and non-printing UTF-8 characters into your site's posts.

    Validating your feed now shows an invalid token at line 290, column 406, which is this tag ...

    <a href="http://www.alessiorinelli.it" target="_blank" title=" Alessio Rinelli  On The Web " class="wp-biographia-link-">Web</a>

    ... if you look closely, the title attribute has what looks like some extra spaces ... I've replaced them here with underscores so you can see what I mean ...

    title="_Alessio Rinelli_ On _The Web_"

    But as they're not printing characters, you can't easily spot them. So I downloaded your feed into a text file and looked at the contents in a text editor which shows all characters, not just the printable ones and I see this ...

    title="^BAlessio Rinelli^D On ^BThe Web^D"

    ... there are these extra -- and invalid -- characters in every link's title attribute. This isn't just in the code that WP Biographia emits, but it's in the content of every one of your site's posts as well.

    I suspect that there's another plugin you have running which is hooked to the WordPress the_content filter that is doing this and that it's running before WP Biographia and so my plugin picks up this invalid content as well.

    I strongly suggest that you disable all of your plugins, validate your feed and if it validates successfully (which I suspect it will) then start to re-enable them, one by one, checking your feed each time, until you identify which plugin it is which is causing this.

    It could also be something inherent in your theme, so I'd recommend reverting temporarily to a stock WordPress supplied theme, such as TwentyTen, to rule this out.

    -Gary

  11. grouperteam
    Member
    Posted 1 year ago #

    Thanks Gary. I will try all your suggestions. I really appreciated your help !
    Franco

  12. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Not a problem. Keep me posted on how you get on please.

    -Gary

  13. grouperteam
    Member
    Posted 1 year ago #

    Thanks Gary I worked all night long but nothing it doesnt work with yr plugin...
    I have to deactivate it unfortunally.
    F

  14. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    I don't understand this at all. Are you saying that the issue goes away if you deactivate WP Biographia? If that's the case, I'm at a loss so see how this could happen. What would be helpful is if you could let me know what other plugins you're using. That way I can try and duplicate your environment and see if there's some odd interaction going on between my plugin and another.

    -Gary

  15. grouperteam
    Member
    Posted 1 year ago #

    yes Gary I will try this morning to settle another pluging just to try if something goes differente and Ill let you know. If I deativate your pluging evething goes fine... Ill try my best and ill let you know surely. thanks

    F

  16. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Haven't heard back from you on this, so I'm making the assumption it's all working for you. Feel free to re-open this thread if that's not the case.

    -Gary

  17. grouperteam
    Member
    Posted 1 year ago #

    Ciao Gary I really appreciate your email. Actually I didnt try again, I deactivate your plug in and now everything is working...im worry to activate it again...because i dont want to reinstall again all the plug in.Im a bit sad about it because i really like your plug in but maybe the problem is the theme...well i dont know it. At this moment I cant change the theme is too much work for me now.
    What else shall i do?
    Thanks again

    Franco

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.