WordPress.org

Ready to get started?Download WordPress

Forums

Problems with embedded Youtube video on mobile platform (3 posts)

  1. ChrisHad01
    Member
    Posted 7 months ago #

    Hi forum, first time post so please be patient! :)

    I've built a wordpress site on v3.7.1 and the front page runs a MP4 file video pulled down from Youtube. The following error message flashes up at the top of the screen "you need flash player 8+ and javascript enabled to view this file". Even though I get this message the video SILL plays OK on the page on a PC browser as it running Flash & Java.

    1st question : if it runs it why does the error flash up
    2nd question and most important is on mobile platform such as phone or tablets! Now I know they don't run flash etc... so would expect this type of error and the video doesn't run on screen!
    One of the reasons the HDvideo when put together for the website was NOT based around Flash or java requirements so it can run on mobile platforms, So cant work out why it requires flash & java for an MP4 file?

    Is there some section in WordPress or plugins/direct embedding that performs this check? and what causing it?

    Any help would be appreciated.

  2. Evan Herman
    Member
    Posted 7 months ago #

    Hi Chris Had,

    You should look into implementing the HTML5 YouTube player. This will avoid the need for flash on mobile devices such as tablets and smart phones. I'm not sure why the error would display (and allow the video to player) if there was no flash supported on the device. Seems like more of a bug.

    Best,
    Evan

  3. ChrisHad01
    Member
    Posted 7 months ago #

    Thanks Evan....

    I thinks it a problem with the video web landing page? Where the video plays full screen under a floating top menu bar. As mention is plays on my laptop but not on a mobile.

    I'm using the Ensconce - Premium Video Landing Page Theme (by webfactory v1.15) and its simple to configure by pasting in the YouTube link (not full url). As soon as the link is pasted the video plays on laptop. (flash & java error does still flash up)

    Since posting yesterday I've don't some further tests to see if the MP4 will play on a new page:
    I created a additional page under the lander page and pasted the video link into the page and the video is pulled down into a YouTube type video box (not full screen) waiting to press play and it is actually PLAYS on the mobile underneath the lander page.

    Im just trying to workout how to get into the Theme code as this is the area that launches the video, full screen when the site is loaded.

    Regards
    Chris

Reply

You must log in to post.

About this Topic