WordPress.org

Ready to get started?Download WordPress

Forums

Problems with "Edit Permalink Structure" (20 posts)

  1. kickass
    Member
    Posted 9 years ago #

    Before I get into the problem, I will mention that I posted this to an already started thread and haven't gotten an answer (over 48 hours.) Apparently that "bold posts are new" thing that isn't working is a problem-- yes, I followed board etiquette, but no, I didn't get an answer.

    http://kickasswebdesign.com/wordpress/

    Now, my problem:
    I'm on an apache 1.3.33 server, kernel 2.4.26. I had wordpress installed and working no problem, all seamlessly and effortlessly and with my spanky new custom theme, woohoo! Well, with the exception of my wp custom 404 page not showing up, which I didn't know about until the REAL problem kicked in.

    I tried to "Edit Permalink Structure". Now everything is screwed up. Permalinks are all 404. Yes, I did the .htaccess thing right. Numerous times. I should mention that I had to edit it manually since the permission on the htaccess is 644. I also tried changing the permission (up to 666) and running the "Edit Permalink Structure" again, but it would not do it automatically no matter what. No, I'm not using "category" in my preferred new url, so that shouldn't be an issue. I'm using /%year%/%monthnum%/%postname%/

    I followed fixes on another thread (yes, my previous posts are there) and tried some things. Installation of the reduced rewrite plugin and a further editing of the htaccess didn't fix the problem (but did get me my custom 404 page). So I tried the ungreedy rewrite plugin (it's what's in use now) which didn't fix it and got me back to a generic 404.

    Now, for this site, though I would prefer search engine friendly urls, I'd be happy to just get it back to the way it was by restoring the default urls, but there seems to be no easy way to do that. Any way in a future version you can just make a button to restore default??? That would be a nice thing just in case someone is on a server with an issue (like mine apparently is)

    There is a site I was planning to use WP on that search engine friendly urls AND "static" Pages (as well as a "static" Page being defined as the entry page for the site) will be critical, and it's with the same host. I'm wondering now if that's at all possible.

    To simplify--

    fix for first site with problem for server it's presently on is MUCH preferred.

    If that isn't possible, how do I simply put it back the way it was? Is there (PLEASE!) one simple file switch I can make along with restoring my original htaccess? Or do I have to do a complete reinstall of WP?

    If fix on my current server isn't possible, has anyone successfully gotten this feature working on a different host? If so, can you tell me where you host? I'll need to consider a server switch for the second site, and will need to shop hosts.

    Any and all help is greatly appreciated.

  2. ColdForged
    Member
    Posted 9 years ago #

    Empty the permalink structure string to get back to "ugly" permalinks.

    The fact that Apache issues a 404 on the complete permalink means to my mind that the rewrite simply isn't happening. I'm no expert on Apache versions, so I don't know what to tell you about getting pretty permalinks in that environment, but I will say that whatever is in your .htaccess right now isn't having any effect on your URL. If it was, by the time Apache got down with it it would be in the form of something like index.php?blahblah.

  3. Does your host have mod_rewrite enabled?

  4. jpettit
    Member
    Posted 9 years ago #

    Just to clarify what ColdForged stated:
    The 'default' is no Permalinks. To restore this delete the content (/archives/%year%/%monthnum%/%day%/%postname%/) out of the Structure field (in Options-Permalinks), and then click 'Update Permalink Structure'.

  5. kickass
    Member
    Posted 9 years ago #

    Thanks everybody!- restored to original, and working, though with the not SE friendly URLs. At least it works again :-)

    Re host- I guess it probably isn't. I asked them about mod_rewrite and got kind of a vague answer about how they didn't plan on doing any updates. I think it's time to shop hosts.

  6. vkaryl
    Member
    Posted 9 years ago #

    Oh joy. WHAT a lovely support tech response. Yup. Time to get someone new....

    I've been with some great folks for years. Not real expensive. ALL the bells and whistles, great tech support, 99% uptime. If you want to look at their stuff, email me sylvermoon (at) gmail (dot) com.

  7. kickass
    Member
    Posted 9 years ago #

    Re wordpress hosting . . . yes, those hosts are on the shortlist, and I hope, if I choose one of those, you're at least getting an affiliate fee. You folks deserve a bit of support for the good stuff you offer here.

    Thank you ALL for your help and suggestions.

  8. brianbonner
    Member
    Posted 9 years ago #

  9. kickass
    Member
    Posted 9 years ago #

    Ya know, I just found that article last night and it did give me one more idea to try to get the dang thing working on the host I'm currently on, and I just haven't had time to try it. But I thank you for the steer, that's a really good and thorough article.

  10. kickass
    Member
    Posted 9 years ago #

    The final followup-- I GOT IT WORKING!!! And I felt like a complete idiot for a few minutes when I realized what it might be, tried it and found out it was that SIMPLE LITTLE THING-- but after re-reading the posts and info in answer to me, the other posts on the same topic in the support section I had found, the basic WP docs, and everywhere else BUT the codex, maybe it wasn't quite my fault since the codex is the only place it's mentioned prominently. Also, those of you who offer advice should add this little tidbit as the FIRST thing to ask re any permalink problem. There's no criticism here, understand, just a re-aligning of your awareness of what (ignorant) mistake a newbie to this script might make given the current docs.

    Are you ready for this one?

    The .htaccess file has to be in the same directory as the wordpress installation.

    Those of you who write the docs should add this prominently- everywhere. It also might have been helpful if it had been mentioned in the admin area entitled "Edit Permalink Structure" where it told me, very clearly, to edit the .htaccess file. I assumed, wrongly, it meant the one that I already had on my site, rather than one that needed to be created exclusively for my wp installation. If the necessary path of the .htaccess file had been mentioned there I would have paid attention, and it would have saved a whole bunch of people (including me) a whole lotta time.

    Thank you all for your help, I now have a KICKASS WP installation with SE savvy permalinks!

  11. jpettit
    Member
    Posted 9 years ago #

    The .htaccess file has to be in the same directory as the wordpress installation.

    Acutally, I believe this isn't quite accurate. It has to be in the same directory as your index.php. If you have your index.php in your wordpress directory then this advice is correct, however, if you move it to your web root, then the .htaccess will be in your root. (this is the setup i have).

  12. Ngan Tengyuen
    Member
    Posted 8 years ago #

    oh my god.... you're all my hero... you're all are my biggest hero. i was about to give up until i come across this article. may i add a few point her for really newbie like me.

    what he meant is that if you have your blog in a different directory, for example http://www.miragestudio7.com/blog then your .htaccess should be inside the "blog" folder.

    thanks a million. ur my heroes.

  13. gfa202
    Member
    Posted 7 years ago #

    Greetings,

    I am desparately trying to resolve similar probelm with permalink structure settings.

    I have installed WP 2.X at http://www.grandgood.com/wordpress/ but I have moved my index.php and .htaccess files to http://www.grandgood.com/. Now when I update the permalink structure to "pretty" format my site gets ruined and the theme disappears. Interestingly though, the content remains (i.e. links, pics) and the urls work. So the permalink structure works, it just destroys my theme.

    Anyone experience similar problem? I will test tonight by moving my index.php and .htaccess files back to http://www.grandgood.com/wordpress/ and see if it resolves.

    (re: theme being used is http://www.iqwolf.org/wordpress-themes/unnamed-one)

    Thanks.

  14. Chris_K
    Member
    Posted 7 years ago #

    @gfa202: you followed this guide? Giving_WordPress_Its_Own_Directory

  15. gfa202
    Member
    Posted 7 years ago #

    Handysolo: Yes, I followed that guide step by step. I actually just finished reverting my site back to the way it was prior to Giving WordPress Its Own Directory. I placed my index.php and .htaccess back into the http://www.grandgood.com/wordpress/ folder and edited the language back to its original state. When I finished the revert and applied the new "pretty" permalink structure my theme not only disappeared but the individual post-links and archives started pointing to 404s.

    So at least now I believe I have deduced that my problem appears to not have anything to do with WordPress being installed in a subdirectory and my index.php being in the root. Once again I have reverted my site back to http://www.grandgood.com/index.php. I'm not sure what to try next.

    As an aside, just as an experiment, I tried changing my permalink structure from the default http://grandgood.com/?p=123 to http://grandgood.com/?p=123/%year%/%monthnum%/%day%/%postname%/

    Magically my template appears after this but above the header I get about 100 error messages.

    Any ideas?

    Thanks for the reply. It is greatly appreciated.

    Update: I also just tried applying a custom permalink structure of /%post_id%/ and of /%post_id%/%year%/%monthnum%/%day%/%postname%/

    mysteriously both, even just /%post_id%/ which isn't it the default?, cause my them to disappear. But interestingly the links to the individual posts work, it's just the template that disappears. :( ?

  16. Chris_K
    Member
    Posted 7 years ago #

    Was just at your site. I see things working with Default permalinks.

    Have looked over the troubleshooting stuff at the Permalinks page?

  17. gfa202
    Member
    Posted 7 years ago #

    Thanks. I reverted back to Default permalinks because I do not want visitors seeing the broken page.

    My next step is to attempt to confirm that my server has the "Apache mod_rewrite module"; I guess I will have to contact godaddy to verify but I know I am on a Linux server.

    What strikes me as strange is that the permalinks work, it's jus that the theme template disappears

  18. gfa202
    Member
    Posted 7 years ago #

    I have just confirmed that Mod_rewrite is installed as default on my server. It appears I am having same problem as Colin-Uk here: http://wordpress.org/support/topic/54012?replies=21

    I will continue trouble shooting and post any progress. Thank you.

  19. moshu
    Member
    Posted 7 years ago #

    I don't have a solution, but for sure you can't have the same problem: the topic you linked to is from January and relates to version 2.0! (and that one had quite a few bugs)

    The latest is 2.0.5.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags