WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
Problems with Archive Creation (4 posts)

  1. pyxis630
    Member
    Posted 4 months ago #

    Plugin Version: 3.1.2

    I'm using a host that has a I/O cap in place. When I run the backup on a small set of files, lets say database dump, it mostly works.

    At the default settings:
    It can crate a tar ball of around 35-40MB, then it stops. However, once it starts creating the tar.gz file it stops after 2-4 MB and the process just hangs. I do not see any errors. Changing PHP to 5.4 seems to make it worse, the process stops sooner.

    Here is what the support guy says: "It looks like it may be getting killed due to hitting the I/O cap for a long duration. Is there a way to set the script to 'nice' the process so it does not run at high priority during the backup generation?"

    I did try to set the script execution time to lower values, down to 9s. 8 seconds will lead to an endless loop where the script starts every seconds at some point. Setting it to 9s and the maximum setting for the server load reduction allows the tar ball to be created but the archive creation will then just stop after a couple of MB. Looks like that this part is the main issue at least on my host. Keeping the archive as a tar file will allow the plugin to finish the process.

    The support guy recommended getting in touch with you, the plugin developer, to see if the server load can be improved (the I/O part via ionice maybe?) or if pigz could be used which can improve I/O usage. Maybe pigz can be added as a 3rd option to the archiving method setting?

    I have this plugin running on other hosts and one has the exact same WP setup (WP version, plugins, obviously no I/O cap) and it runs fine, so I don't think this specific behavior can be blamed on other plugins.

    Question: would the Pro version take care of the issue I'm facing here? Does it have additional settings when it comes to reducing the server load?

    Thanks,
    Sabine

    https://wordpress.org/plugins/backwpup/

  2. Daniel Hüsken
    Member
    Plugin Author

    Posted 4 months ago #

    Hello Sabine,

    Sorry, but PHP gives not many functions to set process priority. And when it is avalibel it is system depending.

    On setting is allredey integrated in BackWPup. If you got to BackWPup > Settings > Tab: Job ther is a setting for reducing server load. Please try some of the settings. If this setting active BAckups wil take longer, it is beacuse the packup prozesse will make many littel pauses.

    The Pro fersion hase no other options for this.

  3. pyxis630
    Member
    Posted 4 months ago #

    Hi Daniel. The server load settings, plus a the timeout setting will only work for the tar ball creation, but not for the archiving part itself.

    I had too set the time out to something very low (9s) and the server load reduction to maximum. That allows the creation of the complete tar ball. There needs to be something that slows down the compression piece as well.

    The support guy mentioned pigz.
    What about this: http://www.php.net/manual/en/function.proc-nice.php
    Could that be an option?

    This could be an extra feature in your paid version if you don't want to add something like this to the free plugin.

    Thanks,
    Sabine

  4. Daniel Hüsken
    Member
    Plugin Author

    Posted 4 months ago #

    Hello Sabine,

    i will try to implement 'proc_nice'. But it not works on Windows and i think the best is only use it if php works in CGI mode.

    pigz has no implementation in PHP. So it must called over commandline and that don't work an all systems.

    You can test the beta Version ther i have made some changes for Zipping and tar.gz. https://github.com/inpsyde/backwpup

Reply

You must log in to post.

About this Plugin

About this Topic