WordPress.org

Ready to get started?Download WordPress

Forums

Problems using localhost (8 posts)

  1. UsAllHere
    Member
    Posted 2 years ago #

    I am trying to learn WordPress using a localhost on my computer. I am very early in the “First Steps With WordPress” tutorial. When I “click on the link that is my site name” I did not get the “twentyeleven” theme I was supposed to get. Instead I get the Apache web page that was set up as my root localhost page when I installed Apache. I have tried to open the twentyeleven theme page using many combinations such as http://localhost/wp-content/themes/twentyeleven/ and http://localhost/wp-content/themes/twentyeleven/index.php. I also tried replacing the contents of my htdocs folder (which is the source of the Apache web page) with the twentyeleven contents. The most I can get is an index of what is in folders. What do I need to do to get the twentyeleven theme to open in a localhost on my computer?

  2. Steveorevo
    Member
    Posted 2 years ago #

    When you access WordPress, you do not go to the theme subfolders. Instead, you will visit the site root where WordPress has it's wp-config.php file, and most notable: index.php. WordPress will 'do the work' for getting the configuration from wp-content/themes/etc. etc.

    Question: Is there a index.html file present that is preventing the index.php from displaying? Typically, you will need to delete the index.html as that will override any index.php that is in the site root.

    For future support, you may wish to reveal what Apache implementation and platform you are using (i.e. XAMPP on Mac, WAMP on Windows, etc.). There are a number of free implementations that can get you going right away, for instance DesktopServer (http://serverpress.com/products/desktopserver) or InstantWP (http://instantwp.com/installation), etc.

  3. UsAllHere
    Member
    Posted 2 years ago #

    I am using Apache 2 on Windows XP with PHP version 5.2.17. The site root where WordPress “has it's wp-config.php file, and most notable: index.php.”, is htdocs. This is also where Apache installed it’s index.html file and default page stuff. When I first tried my site name link the index.html caused the original Apache default web page to load. I removed all Apache files from this site root and rebooted my computer. Now all I get is an index of the contents of the htdocs folder. I should also probably mention that when I first tried to load the WordPress Dashboard, I got nothing until I appended index.php to the end of the url I was supplied by the install.

  4. Steveorevo
    Member
    Posted 2 years ago #

    Ahh. It sounds like you are using an old server that is not configured either. Unlike the aforementioned up-to-date servers that run on XP without issue, you'll need to configure Apache to turn off directory browsing, include index.php in the list of directory default environments, etc. Could you be persuaded to use another compliant server with already configured Apache directives? If not, I believe the answer is in a number of lines within your httpd.conf file. You could try pasting that here and someone familiar maybe able to patch/recognize the issues at hand. :-/

  5. UsAllHere
    Member
    Posted 2 years ago #

    I would not mind using another compliant server. Are what you mentioned in your previous post links to compliant servers? If so, which would you recommend? I am assuming I should uninstall Apache, PHP and Mysql before loading something new to prevent possible conflicts. Is this correct? Would I also want to do a reinstall of WordPress?

  6. Steveorevo
    Member
    Posted 2 years ago #

    By 'compliant' I mean pre-configured and meet the requirements needed to run WordPress. You should uninstall and remove your current server/database engine (apache and mysql) before attempting to run another.

    Full disclosure: I'm the author of DesktopServer.

    Both solutions mentioned above include the latest version or WordPress and are designed specifically to run on your desktop/laptop computer with minimal effort. Both use Apache and MySQL and PHP with more recent versions then what you appear to be currently running.

  7. UsAllHere
    Member
    Posted 2 years ago #

    I was able to google enough info to allow me to turn off directory browsing and include index.php in the list of defaults. It works now. Thanks!!! I never mentioned how many hours I spent modifying config and ini files just to get WordPress to load in the first place. I wish I would have known about "compliant" servers earlier. I expect the next brick wall I hit will cause me to replace what I have now with yours. Thanks again for your guidance on this.

  8. Steveorevo
    Member
    Posted 2 years ago #

    Excellent. Regardless of which Apache 'stacks' you use. It is nice to hear that you were able to get things working. Enjoy!

Topic Closed

This topic has been closed to new replies.

About this Topic