WordPress.org

Ready to get started?Download WordPress

Forums

Problems Uploading images (8 posts)

  1. noteecheslasiesta
    Member
    Posted 9 years ago #

    Hey people. I need a hand!

    Can´t upload images! I get the error (/home/.quico/nosiesta/noteecheslasiesta.com/wp-content ) doesn't appear to be writable by WordPress . I´ve already tried to change directory´s chmod to 777, 766, 765, 755 etc.. and none of them work.
    Don´t know if the root proposed by WordPress is wrong (i´ve also tried just "/noteecheslasiesta.com/wp-content" and "/nosiesta/noteecheslasiesta.com/wp-content" as example)
    The hosting company (dreamhost) told me: " Make sure both the script AND THE DIRECTORY THE SCRIPT IS
    IN are owned by 'nosiesta' AND chmod'd to mode 755 (readable,
    writable, and executable by the owner, but only readable and
    executable by group and world) - even if your script's set-up
    instructions tell you to make it world writable or chmod 777,
    our system requires that permissions be set to mode 755."

    How can I solve this?
    Thanx a lot and excuse my english!

    PD: i´ve seen other post, but none of them solved my problem

  2. gnukerman
    Member
    Posted 9 years ago #

    I had that problem some time ago. I created a new directory wp-images off the root, made it 777, included an .htaccess to prevent hotlinking/access and the problems were gone.

    Since upgrading to 1.5 I reverted to the recommended wp-content and haven't seen the problem.

    I realize this isn't much help, but perhaps you can give it a try. Be sure to change the upload directory to the new one in your options.

  3. KyleGM
    Member
    Posted 9 years ago #

    Tal como dice gnukerman, una alternativa sería crear otro directorio independiente de wordpress (./images) y darle los permisos correspondientes.

  4. noteecheslasiesta
    Member
    Posted 9 years ago #

    Thanx a lot. It works!!

    Hey, funciona!!! Muchas gracias

  5. gnukerman
    Member
    Posted 9 years ago #

    That's what I said. I don't see anyone else's response so I thought I'd offer that as an alternative. :?

  6. gnukerman
    Member
    Posted 9 years ago #

    If the new one works, it's possible the wp-contents wasn't setup just right in your options to make it work right. ??

  7. paulbriandeberry
    Member
    Posted 9 years ago #

    I'm having this same problem but I'm not sure I understand how to fix this issue.

  8. SebMcC
    Member
    Posted 8 years ago #

    Hello all,

    I am haveing problems uplaoding in general.
    It says "It doesn't look like you can use the file upload feature at this time because the directory you have specified (/home/cinema/public_html/wp-content/uploads) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos."

    The weird part is that I have been uploading for months with the same settings and today it decides to not upload.
    Anyway, does anyone know the proper sequence for getting uploads. I am using cpanel.

    Thank you

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.