WordPress.org

Ready to get started?Download WordPress

Forums

Problems moving the site address using a pre-existing subdirectory install (11 posts)

  1. lindabertelsen
    Member
    Posted 1 year ago #

    Hi, I have run into serious unexpected troubles when moving my index.php page, .htaccess file to the root folder while all the other files stay in their wordpress folder.
    On the General setting page when saving the site address in its new position I get the error message: 404 - File or directory not found.
    I cant't move to any other page in the cms part without getting the same message. It's as if there is no access to the backend. I can enter the frontend (site), but no styling there - the photos and links are there without styling. I can enter the login page, but I can't login. I can see the site (as it is now) from both http://resin.gr/wordpress and http://resin.gr.
    What I have done is just to copy the index.php and the .htaccess file to the root and change the require('./wp-blog-header.php') to require('./wordpress/wp-blog-header.php') in the index.php file.
    Link to my site: http://resin.gr

    I hope someone can help, I've tried everything I could think of. Thanks

  2. seoitc
    Member
    Posted 1 year ago #

    I need to see your htaccess code please. It was happened with my site(http://gascash.co) befor and i did fixed it. Send me code so i can help.
    Thanks!

  3. lindabertelsen
    Member
    Posted 1 year ago #

    My htaccess file seems to be empty ??? 0 Kb
    Is this the problem?

  4. elmalak
    Member
    Posted 1 year ago #

    @lindabertelsen,
    If you have access to the backend of WordPress go to Permalinks page and just Save the Permalinks again without changing anything, this should recreate your htaccess file and fix the issue.

    elmalak

  5. lindabertelsen
    Member
    Posted 1 year ago #

    The problem is that I can't access the Permalinks page from the General setting page, I get the error message: 404 - File or directory not found

  6. elmalak
    Member
    Posted 1 year ago #

  7. lindabertelsen
    Member
    Posted 1 year ago #

    I get this message:

    404 - File or directory not found.
    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

  8. seoitc
    Member
    Posted 1 year ago #

    I think u should use htaccess plugin, and yes 0 KB is problem.

  9. lindabertelsen
    Member
    Posted 1 year ago #

    I don't know what to think anymore. I've tried about every option. I also fixed the .htaccess file with the code given on WordPress.org. I've tried to hardcode the wp-config.php with this

    define('WP_HOME','http://resin.gr');
    define('WP_SITEURL','http://resin.gr');
    - with no result

    I tried the same in function.php

    and still no result. My site is still there, but no access to the backend and no styling on site.

  10. elmalak
    Member
    Posted 1 year ago #

    In this case you shouldn't set both Home and SiteURL to be the same.
    Home should be http://resin.gr
    Whereas SiteURL should be http://resin.gr/wordpress

    Can you try that?

  11. lindabertelsen
    Member
    Posted 1 year ago #

    I tried that but without result - both in the function.php and in the wp-config.php hard coding. The funny thing is that some things work while other things don't. I don't see any logic in it.

Topic Closed

This topic has been closed to new replies.

About this Topic