WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problems moving from directory to root (20 posts)

  1. ca204valry
    Member
    Posted 1 year ago #

    Hi

    I have gone through countless threads but none of them seem to work. Here is what I have done so far:

    Blog was hosted on http://www.bisonsridehard.com/home which I tried moving to the root.

    Before I did that I changed the WordPress URL and Site URL as mentioned in http://codex.wordpress.org/Moving_WordPress

    I had changed the index.php earlier which I changed back to the original settings. Set the permissions of the .htaccess file to 666 as mentioned in the codex.

    But I have been getting the Internal Server 500 Error. I understand that this is an issue with the .htaccess file from all the threads I have read.

    I am at this point unable to login to the dashboard to make any changes but I have full access to the DB and FTP.

    Please advise!

  2. ca204valry
    Member
    Posted 1 year ago #

    If I have to make changes to the permalink from phpadmin what should the new settings read like?

  3. ca204valry
    Member
    Posted 1 year ago #

    This is what my .htaccess reads like:

    RewriteEngine off
    <IfModule mod_suphp.c>
    suPHP_ConfigPath /home/bisonsri/public_html/home/php.ini
    <Files php.ini>
    order allow,deny
    deny from all
    </Files>
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /home/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /home/index.php [L]
    </IfModule>

    # END WordPress

    Which I changed to:

    RewriteEngine off
    <IfModule mod_suphp.c>
    suPHP_ConfigPath /home/bisonsri/public_html/php.ini
    <Files php.ini>
    order allow,deny
    deny from all
    </Files>
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

  5. ca204valry
    Member
    Posted 1 year ago #

    Hi Esmi

    I did the steps mentioned in the link you provided. But after doing that I am unable to open the site, and getting a Error 500 message. I am not able to login to the dashboard as well to update the permalinks too

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you reversed all of the changes you made when trying to move to root?

  7. ca204valry
    Member
    Posted 1 year ago #

    Yes I did. All that's mentioned in the link you gave. After which i started getting a Error 500 and not able to login to the dashboard since. I am now going back to the previous state and starting over.

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    So what's the problem with http://bisonsridehard.com/ ?

  9. govpatel
    Member
    Posted 1 year ago #

    Have you tried using ftp to rename the .htaccess file and then try and see if your site opens if it does you can reset your permalinks so that a new .htaccess file is created.

  10. ca204valry
    Member
    Posted 1 year ago #

    Esmi,

    What you see now is the site rolled back to its original state. All the content is back in its original folder.

    Govpatel,

    I tried to rename .htaccess to htaccess.txt but that was of no avail.

  11. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    But what is the problem with that site? It seems to be functioning just fine.

  12. govpatel
    Member
    Posted 1 year ago #

    What you see now is the site rolled back to its original state. All the content is back in its original folder.

    When I click on menu I do not see any folder so you must have your wordpress in root.

  13. ca204valry
    Member
    Posted 1 year ago #

    When the blog was in a directory, I was unable to preview posts and used to open the homepage instead. That is where is entire story started. I guess I better search for a easier solution to the problem!

    GovPatel,

    The reason you see it like that is because the Site URL and WordPress URL have been changed in the settings>General

  14. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    And can you preview posts now?

  15. govpatel
    Member
    Posted 1 year ago #

    The reason you see it like that is because the Site URL and WordPress URL have been changed in the settings>General

    and that is how they should be if you have wordpress in root
    and all your permalinks are working fine as well.

    If you had wordpress in folder home then you would get error

  16. ca204valry
    Member
    Posted 1 year ago #

    esmi

    No its not. Its showing a error 404 now! :-/

    Vineet

  17. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Where is this 404 error occurring?

  18. ca204valry
    Member
    Posted 1 year ago #

    Where is this 404 error occurring?

    When I try to preview a post

  19. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    What url is shown in the browser's address bar?

  20. ca204valry
    Member
    Posted 1 year ago #

    What url is shown in the browser's address bar?

    This seems to have magically resolved! I am closing this thread! Thanks esmi for all your help!

Topic Closed

This topic has been closed to new replies.

About this Topic