WordPress.org

Ready to get started?Download WordPress

Forums

problems importing from blogger (14 posts)

  1. jwbond
    Member
    Posted 8 years ago #

    I successfully setup wordpress, but had problems when I tried to import a blogger style blog. It appears that I did all steps correctly, however it does nothing but reload the import page when I do step 3 by clicking the "OK" button at the bottom of the page.

    Help?!?

  2. moshu
    Member
    Posted 8 years ago #

    Try using the script referred in this thread:
    http://wordpress.org/support/topic/27070
    with the addition described in this reply:
    http://wordpress.org/support/topic/36972#post-240917

  3. Cybernest
    Member
    Posted 8 years ago #

    As I posted yesterday in the post you quote above: http://wordpress.org/support/topic/27070

    I am having problems downloading the script there! I left a message for Skeltoac on his site... and as I say posted in the topic above... neither of which have been answered... yet!

    The download page loads... then I get this:

    "<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href=""

    Can anyone advise??

    Thanks in advance.

  4. moshu
    Member
    Posted 8 years ago #

  5. Cybernest
    Member
    Posted 8 years ago #

    Yep! No problem... except... what should I do with it? lol!

  6. moshu
    Member
    Posted 8 years ago #

    Save it as import-blogger.php in your wp-admin folder to replace the original importer file. Best way to go: delete the original and upload the new one.
    Then try again to import the blogger posts.

  7. Cybernest
    Member
    Posted 8 years ago #

    OK... I thought that's what I would need to do with it! Just wanted to make sure! LOL! I shall try that... watch this space! :) Many thanks!

  8. Cybernest
    Member
    Posted 8 years ago #

    Moshu

    Just wanted to say Many Thanks! The import worked a treat! All posts and comments (not many of those) were transferred perfectly!

    I am having a slight problem with my Archive links which are not opening properly... but I think this is a CSS problem and nothing to do with the Blogger Import tool or process.

    Anyhow... many thanks again!

    Saludos! :)

  9. moshu
    Member
    Posted 8 years ago #

    If by "archive problem" you mean that a lot of html file are opening in a directory listing instead of the real archives... you just have to delete those imported files :)
    (they are already in the database - hopefully).
    Remove them somewhere else, then check the DB archives and, if everything is OK, you can delete those html files.

  10. Cybernest
    Member
    Posted 8 years ago #

    Hi Moshu

    That's exactly what I meant... and I did what you suggested... and Hey Presto! All well now! Thanks once again! You are a veritable font of knowledge! :)

    I wonder if you might help with another question. On my Blogger site... I was able to show the (10) most recent posts on my sidebar along with the Archives listed monthly. How can I show my most recent posts using WordPress? I have been looking around for guidance on this and can't find it. I'm sure it's probably there somewhere... but I can't dig it out? Can you advise or point me in the right direction please... How to show my recent posts on sidebard??

    Thanks again... and in advance! :)

    Saludos!

  11. Cybernest
    Member
    Posted 8 years ago #

    Ah! Sorry... I think I found the answer... Please correct me if I'm wrong... but I think all I need to do is include this:

    <?php wp_get_archives('type=postbypost&limit=5'); ?>

    I shall try it anyway! If I have problems, I shall be back!! :)

    Thank you!

  12. porterboyd
    Member
    Posted 7 years ago #

    on the IMPORT BLOGGER page, i enter my blogger user name and password, and it keeps saying, "Login failed. Please re-enter your username and password." (my user name and password are correct. also, i am logged out of blogger.)

    i think the problem may be that wordpress is checking the wrong directory. when i enter my credentials, it says in the status bar, "waiting for http://www.domain.com" even though wordpress was installed by dreamhost in http://www.domain.com/sub-directory.

    does anyone know how i can fix this?

    thank you.

  13. MrFortune
    Member
    Posted 7 years ago #

    I'm having pretty much the same problem. Except I'm using a different host and my blog isn't in a subdirectory.

    I'm using wordpress 2.0.5. if that matters.

  14. krushinfo
    Member
    Posted 7 years ago #

    Yeah the Blogger Beta to WordPress import does NOT work.. anyone have any ideas on how to transfer these safely?

Topic Closed

This topic has been closed to new replies.

About this Topic