WordPress.org

Ready to get started?Download WordPress

Forums

Problems getting local server test site running properly (10 posts)

  1. bstharp
    Member
    Posted 2 years ago #

    I'm a neophyte with this stuff, but after reading the doc files here:
    http://michaeldoig.net/4/installing-wordpress-locally-using-mamp.htm
    and
    http://codex.wordpress.org/Installing_WordPress_Locally_on_Your_Mac_With_MAMP ...

    I was getting more familiar with what to do. HOWEVER, I want to use my existing WP site that is hosted; So I found this link:

    http://wordpress.org/support/topic/how-to-copy-wordpress-site-to-local-test-server?replies=30

    that helped, somewhat. Here's where I stand:

    I downloaded my WP site folders and put them in Appications/MAMP/htdocs. The folder inside htdocs is labeled xxxxwordpress. (all my wp-admin, wp-content, wp-includes folders and all the wp-xx.php files are in there). In MAMP, I told it the document root of /Applications/MAMP/htdocs. Is that correct or should it say /Applications/MAMP/htdocs/xxxxwordpress?

    I created a database using Launch myPHPadmin from MAMP dialogue box; I then imported the data that I had exported from my live site. All went well with that. Out of curiosity I typed in my browser window: localhost:8888xxxxwordpress/wp-admin. It brings me to my WP admin login page but if I log in there, anything I do affects my live version still. That's because the database hasn't been updated with the local host site name, correct?

    So I have to do those changes in the myphpadmin. However, in the database, I clicked on sql, and pasted the code from the documentation. Now, I should be replacing 'hosted version.com' with my real site name, correct? and the 'localhost' with the local name, but I'm unsure whether I should just be using http://localhost/xxxxwordpress or if I need more path information there. I used 'http://localhost/xxxxwordpress' just to see. That change took (I checked by browsing the sql wp-options table). So I went to the next step, pasting code into wp_posts, for 'guid'. I hit the go button and I get a yellow bar at the top of the window with the spinning wheel, saying LOADING. But how long does that take? I let it run for 10 minutes and it didn't stop….still going in fact! what should I do next? I will have to force it to stop somehow, by clicking on another table in left column perhaps, but I need to get past this and get the changes made in the db...thanks for any help any of you can give....

  2. bstharp
    Member
    Posted 2 years ago #

    Here's an update: I closed my database php window, finally giving up as the spinning wheel and loading bar never went away. When I went back into myphpadmin, I looked at the wp-options table and my site url was now the local host name. cool. I checked in wp_posts, and both 'guid' and the 'post_content' had been changed to the new local host. I went to a browser window and typed in http://localhost:8888/xxxxwordpress/wp-admin and I got in to my dashboard. hooray! I can edit an individual page, and save draft, but when I try to click 'preview' or 'view site' the url's are wrong - they show up as 'localhost/wordpress/. This is a clue I think. In the beginning of all of this I created a test database and the I installed a fresh copy of wordpress. While that worked, I wanted all my data and theme files, so I quit MAMP (I think) and moved wordpress out of the htdocs folder, and moved my wordpress site files in instead.Things seemed to be fine but for this link issue. The fact that the 'go' action in my local host site is looking for wordpress not xxxxwordpress tells me something's not right, but what? I can't preview my page changes.

  3. bstharp
    Member
    Posted 2 years ago #

    I'm getting sooooo close to this working. I looked at my settings>general and found my site address url was set to http://localhost/wordpress, not testwordpress. I cleared that out and saved changes and it installed the same url as the wordpress address in the line above it. When I type in http://localhost:8888/ I get my directory of wp-xxx files/folders in a list but not my actual site as below:

    Index of /testwordpress
    Parent Directory
    google-news-sitemap.xml
    stats/
    wp-activate.php
    wp-admin/
    wp-app.php
    wp-blog-header.php
    wp-comments-post.php
    wp-config.php
    wp-content/
    wp-cron.php
    wp-includes/
    wp-links-opml.php
    wp-load.php
    wp-login.php
    wp-mail.php
    wp-pass.php
    wp-register.php
    wp-settings.php
    wp-signup.php
    wp-trackback.php
    xmlrpc.php

    There's something that I'm missing here. I can't see my actual site with all the theme/formatting in place. I can work on my docs but not preview them as the preview button takes me to the same browser page with the list just shown above. How can I tell get my theme to actually take control? How do I see my site? All the tutorials and forum discussions I've read the past two days mostly talk about creating a fresh wordpress site. the one forum posting I read about putting a copy of your site on a local server got me this far, but now I'm stuck. Please help if you can. many many thanks and good karma coming your way for any answers!

  4. Baguio Ads
    Member
    Posted 2 years ago #

    Put those files inside htdocs, no subfolder or what. Because, if you created a sub folder inside htdocs, then the site shall be accessible via,
    http://localhost/subfolder.

    or

    http://localhost/testwordpress

  5. bstharp
    Member
    Posted 2 years ago #

    Thank you for your answer Baguio. I figured out very late last night that I also didn't have my index.php file in the right place. Once I did both of those things, it all worked great!

  6. frovin
    Member
    Posted 2 years ago #

    Been reading your thread, BSTHARP, with great interest! The thing is I have a problem SOMEWHAT similar. Yesterday, I completely lost the possibility to go from DASHBOARD to MY SITE (on localhost) to view changes.

    I got the error message from SAFARI that there are too many redirects. In one forum it was suggested that the problem could be used by clearing cache, history/cookies etc.
    Which I did! No result!

    Another forum suggested changing browser - that the problem was with SAFARI. This morning I downloaded Firefox - what happened when I entered http://localhost:8888/wordpress???? Same thing - an error message indicating that I had
    redirections on the page pointing at itself (so it would never end!)

    When I installed MAMP and WordPress (and the theme of my site), I followed the instructions in a youtube video, and it worked out well.

    I am really blocked and do not know how to get further!!!

    Being a newbie, I do think sometimes suggestions are what we in Denmark call 'black talk' - i.e. something absolutely incomprehensible. I therefore trust I can get help here, as the problem seemed similar to a certain degree - in a language I can understand and that tells me exactly what to do!

    In relation to the above: in my Settings (in the dashboard), the URL is listed as http://localhost:8888/wordpress, so that should be correct, right? My files are in htdocs in the folder 'wordpress' (as was the instruction in the youtube video), also ok, right?

    HELP! & Thanks a lot.

    Jesper

  7. bstharp
    Member
    Posted 2 years ago #

    Hi Jesper - it can be frustrating! Make sure in settings that your WordPress URL and the Site Address URL are the same. I had problems until I noticed that one was still the live site...that might help in the redirect problem. I can't help much beyond that, I'm so new to this sort of thing. Hopefully that might help you!

  8. bstharp
    Member
    Posted 2 years ago #

    I stand corrected - My Site Address URL was localhost:8888/wordpress, not XXXXwordpress, which was the name of my local wordpress site. The bottom line is they must match!

  9. Baguio Ads
    Member
    Posted 2 years ago #

    glad you've resolved it. it's been a journey.

    just want to ask you these bstharp, does MAMP automatically uses port 8888 as the default one?

    sorry i've asked, i don't have a mac coz i don't afford one. i use wamp by the way.

  10. bstharp
    Member
    Posted 2 years ago #

    Yes, it does use 8888 as the default port.

Topic Closed

This topic has been closed to new replies.

About this Topic