WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] problems creating a child theme (18 posts)

  1. suecarroll
    Member
    Posted 5 months ago #

    I am fairly new to wordpress.org and have built a site with the clean retina theme. As I wanted to make some changes with code I have tried to build a child theme. However, although I have managed to create the child theme and activated it, I cannot get it to take the parent theme’s design. Everything just appears like a list of details.

    The site is http://www.christopher-dyson.co.uk (my husband)

    Here is the .css sheet I created;

    /*
    Theme Name: Clean Retina Child
    Theme URI: http://www.christopher-dyson/clean-retina-child/
    Description Clean Retina Child Theme
    Author Sue Carroll
    Author URI: http://www.christopher-dyson.co.uk
    Template: clean-retina
    */
    @import url(“../clean-retina/style.css”);

    Also my name is coming up as anonymous under the child theme
    I have swapped back to clean retina just to allow the child theme to update and deactivated all plug ins. I have searched on this forum but still cannot find out what is wrong.
    As I say, I am new to all this so could anyone tell me if there is anything obviously wrong I am doing?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 5 months ago #

    You need to replace the fancy quotes in @import url(“../clean-retina/style.css”); with plain double quotes.

  3. suecarroll
    Member
    Posted 5 months ago #

    Have done this, will try again

  4. suecarroll
    Member
    Posted 5 months ago #

    Thanks for that reply. I've changed to plain quotes (I think)but it's still not taking the parent theme. (I had created the .css in WORD not Notepad)

    Is this right?
    @import url("../clean-retina/style.css");

  5. alchymyth
    The Sweeper & Moderator
    Posted 5 months ago #

    Also my name is coming up as anonymous under the child theme

    you missed to add the : in those lines -

    Description:	Clean Retina Child Theme
    Author:	 Sue Carroll

    everything else seems to be working now (?)

  6. suecarroll
    Member
    Posted 5 months ago #

    Thanks, it's now showing my name but still isn't taking the parent theme! This is the style sheet now;

    /*
    Theme Name: Clean Retina Child
    Theme URI: http://www.christopher-dyson.co.uk/clean-retina-child/
    Description: Clean Retina Child Theme
    Author: Sue Carroll
    Author URI: http://www.christopher-dyson.co.uk
    Template: clean-retina
    */

    @import url("../clean-retina/style.css");

    Is there anything else wrong?

  7. alchymyth
    The Sweeper & Moderator
    Posted 5 months ago #

    a child theme does not automatically take the customization you might have done with the parent theme;

    you will need to re-do all the 'header' etc settings under dashboard - appearance etc...

  8. suecarroll
    Member
    Posted 5 months ago #

    Ok, should I remove customisation and start again? I thought it would at least take the bits of the parent theme that I haven't changed

  9. alchymyth
    The Sweeper & Moderator
    Posted 5 months ago #

    it would at least take the bits of the parent theme that I haven't changed

    as far as I can see, your site seems to be taking the default styles of the parent theme.

    this forum does not have the comparison to what your site looked with the parent theme activated; you could post some screenshots to illustrate what the difference is between how the site was with the 'clean-retina' theme directly, and with the child theme right now.

    if this gets into specifics of the theme layout, please continue the discussion by starting a new topic in the theme's forum at http://wordpress.org/support/theme/clean-retina#postform or, as the theme author suggests, directly at http://themehorse.com/support-forum/

  10. suecarroll
    Member
    Posted 5 months ago #

    It is working on my husband's pc but not on my laptop. This is what it looks like on my laptop. (Hope this works - I have just had to go off and learn how to take and post a screenshot)

    http://www.christopher-dyson.co.uk/wp-admin/post.php?post=210&action=edit

  11. esmi
    Theme Diva & Forum Moderator
    Posted 5 months ago #

    Try emptying the browser cache on the laptop.

  12. suecarroll
    Member
    Posted 5 months ago #

    I did this yesterday. Should I try again as I have made changes to the website? (Bit clueless)

  13. esmi
    Theme Diva & Forum Moderator
    Posted 5 months ago #

    Yes.

  14. suecarroll
    Member
    Posted 5 months ago #

    Ok, I went to internet options and deleted browsing history (right?) and activated another theme, then activated my child theme again - but it still looks exactly the same as above screenshot.

  15. alchymyth
    The Sweeper & Moderator
    Posted 5 months ago #

    this is how it looks on my laptop Firefox browser
    http://imageshack.us/photo/my-images/19/x372.jpg/

    can you temporarily switch back to the parent theme to illustrate the layout?

  16. suecarroll
    Member
    Posted 5 months ago #

    Yes, have done that now alchymyth - it looks slightly different to your browser, it hasn't got the header I have been trying out

  17. alchymyth
    The Sweeper & Moderator
    Posted 5 months ago #

    I see this: http://imageshack.us/photo/my-images/46/kmce.jpg/

    that header image needs to be re-inserted in the child theme under dashboard - appearance - header; the same needs to be done to any other customization you might have done via the 'appearance' panel.

  18. suecarroll
    Member
    Posted 5 months ago #

    Not sure how but the parent theme is now coming through on the child theme on my laptop. I just need to redo any customisation now. Brilliant!

    Thanks to everyone above for taking the time to help me, I really appreciate it

Reply

You must log in to post.

About this Topic

Tags