WordPress.org

Ready to get started?Download WordPress

Forums

Problems configuring WPG2 with Gallery2 URL Rewrite plugin (3 posts)

  1. lwalewski
    Member
    Posted 5 years ago #

    Hi,

    I am having troubles configuring WPG2 with Gallery2 URL Rewrite plugin. I enabled permalinks in WP and they work fine with the posts. Then I installed and enabled the URL Rewrite plugin in Gallery2. When I visit the gallery directly (not via WPG2) - short URLs work fine for the galleries/pictures/etc. When I visit the gallery through WPG2 the links look like PATHINFO permalinks (i.e. they contain index.php) however they do not work (i.e. I get the "Not found" errors for both galleries and individual picutures). When I then go to the WPG2 settings tab in WP configuration panel I get the following message:

    Warning: Gallery2 Rewrite Plugin was deactived
    WPG2 has automatically deactivated the Gallery2 Rewrite Plugin, to reactive, enable Gallery2 Rewrites in the WPG2 Gallery2 Rewrites Tab.

    When I go to the WPG2 Gallery2 Rewrites Tab I get the following:

    Error: Gallery2 Rewrite is not using mod_rewrite
    Gallery2 Rewrite module is not using Apache mod_rewrite and cannot be supported within the WordPress Environment, please configure the Gallery2 Rewrite Module to use Apache Mod_Write.

    And no option for activating it back is available. So then I go to the Gallery2 configuration panel and activate the URL Rewrite plugin again. Here the loop closes, i.e. the URLs work fine in Gallery2 but not in WPG2, so I go to the WPG2 panel and get informed that the Gallery2 Rewrite Plugin was deactived and so on.

    How can I resolve this ?

    Thanks and regards,
    Lukasz

  2. sbollapa
    Member
    Posted 5 years ago #

    Am also having similar issues.
    Posted the question to gallery forums with no reply.. hope some one responds here..
    now my gallery is broken

  3. Russel Fones
    Member
    Posted 5 years ago #

    If your gallery is broken try this: from WordPress's Admin, go to WPG2 > Gallery2 Rewrites screen turn the Rewrite Plugin off, then go to the Plugins screen and deactivate WPG2, and then active WPG2 again. Then hit the main WPG2 screen in the WordPress admin so that WPG2 can validate again.

    Your gallery should be working now (without rewrites), if it's not then you had a different problem then me. Now to fix the rewrites. Go to you gallery Site Admin. Active the URL Rewrite plugin. Go to the URL Rewrite settings page in the Gallery Site Admin. Make sure to uncheck 404 File not found, this is what is interfering with WordPress's rewrites and causing gallery to display a 404 error message instead of just passing off the rewriting to WordPress. Now go and turn on the Rewrite Plugin from the WPG2 Rewrites screen in the WordPress admin.

Topic Closed

This topic has been closed to new replies.

About this Topic