WordPress.org

Ready to get started?Download WordPress

Forums

Virtue
[resolved] Problems after update (32 posts)

  1. filamentworld
    Member
    Posted 9 months ago #

    Hello,
    i got some problems after updating the virtue theme to 1.7.7
    Everything is set back to default, from css changes, to menues, everything. My logo disappeared, my background is gone etc...
    I have to start from ground up.

    Is it normal? I hope it is´nt.. because i wouldnt update anymore.

    I hope there is a way to restore it.

    Thank you

  2. Kadence Themes
    Member
    Theme Author

    Posted 9 months ago #

    This isn't normal, With version 1.7.5 and higher I had to change the theme options panel. There is a script that runs when you activate that checks to see if you have any theme options in the database then it copies those options to the new.

    Try deactivating and reactivating your theme. Else you can revert back to the previous version http://wordpress.org/themes/download/virtue.1.5.6.zip

    and send me an email with a temp login and I'll try to see if I can get your theme options to transfer.

    ben@kadencethemes.com

    Kadence Themes

  3. filamentworld
    Member
    Posted 9 months ago #

    Thank you so much for the quick reply.
    I´ll try it.

  4. filamentworld
    Member
    Posted 9 months ago #

    Deactivating and activating worked!
    Thank you very much again for the good advice i´ll rate you good for shure and probably buy the full version.
    Excellent service!

    you saved my day

  5. thisisnotlondon
    Member
    Posted 9 months ago #

    I had the same issue as this poster and tested it on 2 sites - got the same results.
    I also tried backing up the site using virtue panel but couldn't access of backup from 1.5 in 1.75.
    I'm guessing best bet is to do full backup before updating them -try the theme activation/deactivation and if that doesn't work use the wordpress backup

  6. Kadence Themes
    Member
    Theme Author

    Posted 8 months ago #

    Hey, there is a tab now in the theme options that allows you to copy previous options panel data and import into the new options panel. You can download here:

    http://wordpress.org/themes/download/virtue.1.8.0.zip

    Kadence Themes

  7. computersimple
    Member
    Posted 8 months ago #

    I had this same problem, I am even using a child theme and all my options were deleted. I deactivated the child and reactivated and some of the settings came back, this is really frustrating after spending a large amount of hours customizing and doing everything to prevent overwriting during update by creating the child theme and it still overwrites? this is kind of a waste of time

  8. Kadence Themes
    Member
    Theme Author

    Posted 8 months ago #

    Hey,
    This is only because of an options panel update and your settings are not lost. If you use version 1.8.0 there is an easy way to import theme settings into the new options panel.

    Send me an email with a temp login and I'd be happy to do if for you.

    ben@kadencethemes.com

    I truly am sorry for the confusion this has caused, I didn't want to have to change the theme options panel but wordpress.org required it and in the end it will be for the better. this panel has better options for transferring and saving your settings.
    And for the foreseeable future the won't be issues of having settings disappear when you update.

    Kadence Themes

  9. computersimple
    Member
    Posted 8 months ago #

    I was lucky enough to use the 'history' mode of my host provider and bring all my files back from yesterday prior to updating - I did nothing to change the database back to yesterday however and everything is back to normal. I would consider pulling this update from wordpress repository - there seems to be something wrong with it.

  10. Kadence Themes
    Member
    Theme Author

    Posted 8 months ago #

    I don't understand something wrong with the download file?

  11. Shane Holloman
    Member
    Posted 8 months ago #

    yes the download file is corrupted and won't unzip

  12. Kadence Themes
    Member
    Theme Author

    Posted 8 months ago #

    That was strange, I guess wordpress.org had an issue with the file when I updated. Anyway just re-uploaded and made it version 1.8.1 seems to work now.

    http://wordpress.org/themes/download/virtue.1.8.1.zip

    Kadence Themes

  13. bridieamelia
    Member
    Posted 6 months ago #

    Hi I've experienced a similar problem, except that I'm trying to go from 1.5.4 to 1.9.?... I am using a child theme. I had clicked backup and figured a backup was saved on the server, no option to download. Upgraded then refreshed the frontend and all the options had disappeared. I deactivated and reactivated but to no avail.

    To fix it for now I have restored the old version, thanksfully all my options are now there...but it seems I can't backup/download and then restore after upgrade so am a bit stuck...any help/advice would be greatly appreciated!

  14. bridieamelia
    Member
    Posted 6 months ago #

    It is a great theme by the way :)

  15. filamentworld
    Member
    Posted 6 months ago #

    Hey there Kadence themes, right now i'm using virtue version 1.8.1. I am not shure if i should update to 2.0, because wordpress tells me all my changes might be lost after an update.
    What do you say?

    Thanks for your great support guys!

  16. Kadence Themes
    Member
    Theme Author

    Posted 6 months ago #

    Bridieamelia,
    Take a look at this: http://www.kadencethemes.com/updating-virtue-with-new-options-panel/

    It explains how after you update from a version below 1.5.6 you need to import your options into the new options panel.

    filamentworld,
    Updating from 1.8.1 to 2.0 shouldn't cause any problems. If you've done any changes to the actual theme files then those will be lost but if you are only wanting to keep your theme options they will all be there after the update. And you can export them before you update just in case.

    Kadence Themes

  17. filamentworld
    Member
    Posted 6 months ago #

    So, i updated.
    And... all my chanegs are gone!
    I saved all my settings before in this .json file. But the import doesnt work.
    Do you have any idea.
    I already tried deactivating and activating again. Worked the last time for me...

    Thanks

  18. filamentworld
    Member
    Posted 6 months ago #

    I am back on 1.8.1, some changes were able to import, some other arent... this really sucks. last update for me. sorry, i love your plugin an your support ist great, but this is a lot of hassle every time. not worth it.

  19. Andrew
    Forum Moderator
    Posted 6 months ago #

    Where did you make your changes?

  20. Andrew
    Forum Moderator
    Posted 6 months ago #

    Where did you make your changes?

  21. filamentworld
    Member
    Posted 6 months ago #

    Some in the theme options an some in the css file direct...

  22. Andrew
    Forum Moderator
    Posted 6 months ago #

    It doesn't matter which theme you use, if you change the original theme files those changes will be erased when the theme updates.

  23. Kadence Themes
    Member
    Theme Author

    Posted 6 months ago #

    Sorry filamentworld, I had thought I made it clear above that if you make changes to the theme files those will be lost. You need to use a child theme if you are making theme file changes.

    Kadence Themes

  24. Marekant
    Member
    Posted 6 months ago #

    I've set up three WordPress sites on localhost. On the third site I installed the virtue theme. After populating the home page with content (text and images) I tried to get rid of the Page Titles by adding the code to the custom.css style sheet.

    I returned to the Home page to see that the title was still there. I can't remember what I did next but I could no longer load the site. In phpMyAdmin, it said that 'no tables were found in the database.

    The site folders still contained the data but the site would not load.

    I deleted the database. Re-installed WordPress. Created a new database and was up and running again. I set up the twentyfourteen theme and then switched to the virtue theme. Again the site won't load. Unlike the first problem, this time the database still contains the tables, so why won't the site load?

    I am not a web developer, so even if I use the right terms, that doen't mean I understand them.

    I'll be very grateful for any help

  25. Kadence Themes
    Member
    Theme Author

    Posted 6 months ago #

    Hey,
    So there isn't a custom css style sheet in the theme, if you added code to the custom_css.php file then that would not be good. It's a dynamic file and editing it without understanding it would cause your site to crash. As a general rule be careful editing php files. But you were on a local host so thats good training.

    Now to explain: In your theme options > advanced settings tab there is a custom css box. that is where you could add the code you wanted to hide the page titles.

    So best thing is to delete the virtue you edited the custom_css.php file and re-download a fresh copy of the theme.

    Hope that helps,
    Kadence Themes

  26. DaQuizz
    Member
    Posted 5 months ago #

    Hi

    I am trying to update from version 1.5.3 to 2.0.5 and also followed your updating tutorial.
    I have set theme update import to on and saved settings but the script window is empty there is nothing to copy.
    What am i missing? I have also tried to deactivate and activate.
    Only home page shows up and pictures and menus are missing.
    I also have updated to virtuetools 1.5 and wordpress 3.8.1

    Thank you in advance

  27. Kadence Themes
    Member
    Theme Author

    Posted 5 months ago #

    are you using a child theme? or were you? Or is the theme folder name something different then virtue?

    Kadence Themes

  28. DaQuizz
    Member
    Posted 5 months ago #

    I have and had no child themes but the virtue folder had a different name.
    Changed the name back to virtue and now i get {"redux-backup":"1"}
    I copied that into import and clicked import - but it still makes no difference...
    Still get only homepage and no pictures in slider and no menu also the title font did not change.
    I can see the menu structure in WP dashboard but not on the page and also can i get access to the different pages through dashboard.
    What am i doing wrong?

  29. Kadence Themes
    Member
    Theme Author

    Posted 5 months ago #

    the old theme options where saved based on the folder name, so whatever your previous folder name was that is what you want to add into the box where you right the child theme folder name. Basically you are telling the theme were to look for the theme options data.
    If you had had your theme named virtue, which was standard not sure how you got something different. Then the theme would have your information but since it was something else you have to tell the theme where to look.

    Just add the previous folder name to the child theme name text box on the update options page.

    Kadence Themes

  30. DaQuizz
    Member
    Posted 5 months ago #

    Oha, that was it! My fault i have added version number to the folder name. I really have learned something, now everything works.
    Thank you very much for great support and great theme!!!

Reply »

You must log in to post.

About this Theme

About this Topic

Tags