WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Problems after update! (15 posts)

  1. Any
    Member
    Posted 1 year ago #

    Thanks for a great plugin!
    Unfortunately I am having some issues after the update...
    I have another plugin called soliloquy (slideshow) and after the update it only shows on the site that is my default language. I tried adding new pages and it works in my default language but not in my second language (which it always had up until yesterday). The shortcode is still there but it doesnt display... PLEASE HELP!

    http://wordpress.org/extend/plugins/polylang/

  2. Any
    Member
    Posted 1 year ago #

    Another BIG BIG problem.... After the update my first page redirects to my second language, what have you done? Can you please fix this, thank you!

  3. boompop
    Member
    Posted 1 year ago #

    I'm having the same problem of my site redirecting to my second language after the most recent update. I have english as the default language and spanish as the second language but when you go to what should be the default english homepage it redirects to the /es/ homepage. Thanks...

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    From changelog:

    * Now a returning visitor is redirected to its preferred language when visiting the front page in the default language

    So how should it work now?
    * If (inside your site) you have a link to 'yoursite.com', then you should access to the English page (the default language).
    * If you are typing 'yoursite.com' in the address bar of your browser (or use a favorite link or click on a link from outside your site), then you are redirected to your preferred language (the last one you browsed since you are a returning visitor).

    @Eineren
    From which version did you update? Did you check if there is not a post type that you should activate in the Polylang settings?

  5. boompop
    Member
    Posted 1 year ago #

    Hi Chouby... Ok, thanks for clarifying that. I see how the auto redirect is working now. If we wanted to turn that off is there a way to do that? I'm not sure if my client will want the user to be auto redirected to the last language they used.

  6. leods92
    Member
    Posted 1 year ago #

    @boompop
    I don't think turning this feature off is useful at all.
    I mean, if someone accessed the content in a certain language once, why wouldn't him/her in the future? Chances are that he or she will stay with the same language. If he/she wants to keep moving between languages, then they'll have to click a little more; but that kind of people are not the majority.

    @Chouby
    Great job! I'm so glad you fixed it so quickly.
    I have a problem though: the tag cloud stopped working for some reason.
    Are you aware of that? Thanks!

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @boompop
    No there is no option to change this. I thought this change as an improvement.

    @leods92
    I have no problem with the tag cloud. Can you precise what is the problem and which tag cloud you are referring to (widget on frontend ? admin ?) and check if your issue is not coming from a conflict with another plugin ?

  8. leods92
    Member
    Posted 1 year ago #

    @Chouby
    I'm referring to the widget on the front-end.
    I'm getting some SQL errors in the server log regarding tags, that's probably connected with the problem I'm having. As I host my blog in Heroku, I have to use PostgreSQL and maybe that's an incompatibility. Did you change any queries in the last version?

  9. Any
    Member
    Posted 1 year ago #

    The auto direct is not working anymore... When I type in my websites address I get redirected to the homepage of my second language... Can you please fix this! Thank you

  10. leods92
    Member
    Posted 1 year ago #

    @Eineren
    That's how it's supposed to work.
    It shouldn't redirect to the main language but to the user's language.
    Choosing the language is not up to you, it's a user's decision.
    Once he/she change to the main language the auto-redirect you redirect to the main language. However, if the user browser or cookie has as the preferred language the second language that will – and should – be the default for that user.

  11. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @leods92
    Yes I changed the where clause of the SQL query from:

    [where] => tt.taxonomy IN ('post_tag') AND tt.count > 0 AND pll_tm.meta_key = '_language' AND pll_tm.meta_value IN ('3')

    to:

    [where] => tt.taxonomy IN ('post_tag') AND tt.count > 0 AND pll_tm.meta_key = '_language' AND pll_tm.meta_value IN (3)

    Notice the string changed to number at the end. Does it correspond to the errors you get?

  12. leods92
    Member
    Posted 1 year ago #

    Exactly!

    LINE 1: ...l_tm.meta_key = '_language' AND pll_tm.meta_value IN (4) ORD...
    ^
    HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts. for query SELECT t.*, tt.* FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON t.term_id = tt.term_id LEFT JOIN wp_termmeta AS pll_tm ON t.term_id = pll_tm.term_id WHERE tt.taxonomy IN ('category') AND tt.count > 0 AND pll_tm.meta_key = '_language' AND pll_tm.meta_value IN (4) ORDER BY t.name ASC made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/yyb/index.php'), get_sidebar, locate_template, load_template, require_once('/themes/yyb/sidebar.php'), dynamic_sidebar, call_user_func_array, WP_Widget->display_callback, WP_Widget_Categories->widget, wp_list_categories, get_categories, get_terms

  13. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    OK. Could you try the development version and tell me if it corrects your issue ?
    http://downloads.wordpress.org/plugin/polylang.zip

  14. leods92
    Member
    Posted 1 year ago #

    Yes, it does.
    I'm sorry but as I'm in a hurry I didn't check what were the changes.
    Have you just rollback the SQL change?
    Anyway, thanks a lot! :)

  15. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    That's exactly what I did. In 1.0.2, I made a mistake when adding the possibility to query more than one language (for use by other plugins).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.