WordPress.org

Ready to get started?Download WordPress

Forums

Problems after transferring domain and site (22 posts)

  1. philiphotog
    Member
    Posted 2 years ago #

    Hi folks. I hope you can help me.

    I just transferred my domain and wordpress files to a new server.

    I'm having numerous problems. My site is http://www.philipthomasblog.com
    1. My website now states I have no index page. Earlier it was just a blank page.
    2. Many of my images have become unlinked.
    3. I can access my admin and log in but I've noticed, even though the posts are there, the images are not.
    4. When clicking on individual posts in my admin area, I can view text, but images are broken: For example: http://www.philipthomasblog.com/2011/11/21/wedding-nicole-josh/

    Can anyone help me to resolve, please.

  2. rakesh mohanta
    Member
    Posted 2 years ago #

    Dear philiphotog,this is a .htacces issue,make sure that wordpress is installed in your webhosting root folder,login to the hosting space through FTP and find if there is any .htacces file,if u find then just delete it

  3. Tim S
    Member
    Posted 2 years ago #

    Hi,

    You do not need to delete the .htaccess file. Simply rename the file and see if that resolves the issue. Also, you may want to reset your permalinks if your URL has changed.

    Kepp in mind that WordPress is URL specific so if you have moved a site from one URL to another you will need to update the site URL and home accordingly.

  4. philiphotog
    Member
    Posted 2 years ago #

    Thanks so much for helping. Ok, I found that file and renamed the it. Still the same problem.

    All files are in a public_html folder and I have the domain pointing to that as a subdirectory. Should I try pointing to a file inside the public_html folder? Should I try moving the files into the root directory instead?

    As for my other issues of not findingimages, how do I reset the permalinks. My url has not changed so perhaps this will not help in finding the images.

  5. Tim S
    Member
    Posted 2 years ago #

    If you want wordpress to work on your domain name without a sub directory the files should be located in the root. When I visit the link:

    http://www.philipthomasblog.com/2011/11/21/wedding-nicole-josh/

    It shows me a domain landing page and not a site. When I go to:

    http://www.philipthomasblog.com

    It says there's no index page to display in the folder. The public_html folder is your web root. Thats where the files should be. Was your site live? Are the nameservers pointed to the correct server?

  6. philiphotog
    Member
    Posted 2 years ago #

    Hi Tim,

    Thanks again.

    The nameservers are correct. I just transferred everything over to Fatcow.

    I can access the admin area so I know that's working and the site is live.

    Please correct me if I'm wrong, but are you suggesting I move the files out of the public_html folder and move them into the root and have the domain without the sub directory?

  7. Tim S
    Member
    Posted 2 years ago #

    No, I was suggesting that you make sure they are in the public_html folder which is your web root. When did you transfer the domain? It looks like it may be still propagating.

  8. philiphotog
    Member
    Posted 2 years ago #

    I transferred the domain and files Saturday evening. Is there a way to know if it is propagating?

    As I mentioned, I can access the admin area without any problems. Is there a file in the public_html folder that I could try pointing the domain subdirectory to?

    Also, I have an index.html in the root directory that is nothing to do with my blog. Should I try try moving that?

  9. Tim S
    Member
    Posted 2 years ago #

    Yes, if you are using wordpress in the public_html folder and you have another file you'll need to rename or remove it. I can look to see what nameservers are currently.

  10. philiphotog
    Member
    Posted 2 years ago #

    I have the nameservers set up as

    ns1.fatcow.com
    ns2.fatcow.com

    and it was confirmed by my old host that they are pointing correctly.

  11. Tim S
    Member
    Posted 2 years ago #

    I dont see the wordpress installation when I visit your domain at all. Actually, I get a page saying there's no index files present. Did you update the site url and home settings to reflect the current domain?

  12. philiphotog
    Member
    Posted 2 years ago #

    The domain name hasn't changed nor has the site url. I just transferred the domain to a new server.

    I can access the wordpress admin her http://www.philipthomasblog.com/wp-login.php and enter my password and see the dashboard area as normal. I'm at a loss what to do.

  13. Tim S
    Member
    Posted 2 years ago #

    Yeah, that works. just not the front facing stuff. Make sure you migrated all of the files and folders over, as well as the database. When you migrated the database, you should have created a new database and imported the contents.

  14. philiphotog
    Member
    Posted 2 years ago #

    Yes, I did do those.

    I'm wondering if I should try again and upload via Fetch FTP all inside a zip folder this time and unload on the server. Not sure if I can do that, but maybe some of the files didn't go through or something.

    I did indeed import the database and create a new one. I noticed I have two databases. Should I remove one of them?

  15. Tim S
    Member
    Posted 2 years ago #

    Nah, I wouldn't remove anything just yet. I'd try to upload the files again to see if something was missed. I've done that before. Also, look in your file manager and see if there's a index.php file in your public_html folder. When I visit the site it's not finding an index file.

  16. philiphotog
    Member
    Posted 2 years ago #

    Yes, there is an index.php file in the public_html folder

  17. philiphotog
    Member
    Posted 2 years ago #

    I've tried twice already uploading all the files. Weird this.

  18. Tim S
    Member
    Posted 2 years ago #

    Sounds like your server is not picking up the handler for php. Typically, you have to tell Apache how to handle extensions. What has your hosting provider said? I'd put up a basic index.php page and see if that displays correctly. If it doesnt than its a server issue. If it does, you know its wordpress related.

  19. Tim S
    Member
    Posted 2 years ago #

    You can try to create a PHP info page with the code below.

    <html>
    <head>
    <title> PHP Test Script </title>
    </head>
    <body>
    <?php
    phpinfo( );
    ?>
    </body>
    </html>

    Save it as info.php and try to visit it in the browser. If it works PHP is working correctly.

  20. philiphotog
    Member
    Posted 2 years ago #

    What program should I use to add this code? I'm on a mac. TextEdit?

  21. Tim S
    Member
    Posted 2 years ago #

    If wordpress admin works, then PHP should be fine. So renaming the htaccess file did not solve the issue? It sounds odd. When I go to /index.php it re-directs to the /index.html page which incidently does not exist. Is there a re-direct set up in your cPanel?

  22. philiphotog
    Member
    Posted 2 years ago #

    Ok, I will not do anything there then. Yes, I have renamed the htaccess file. I'll have to check on the redirect possibility.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.