WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problems accessing admin Panel after attempting to Move site (14 posts)

  1. element art
    Member
    Posted 2 years ago #

    Hi there,

    I'm in a bit of a predicament. I'm a WordPress newbie with a background in Design so I was delighted to be able to create websites using wordpress. I loaded up WordPress onto the site and I think my hosting package created a default "WordPress" folder. (www.mysite.com/wordpress) I created the website and everything is working fine when I viewed the site through wordpress but I needed to get it into the root folder.

    Now this is when everything went wrong. I looked for the tutorials on moving your site to the root folder and followed the instructions as closely as I could (http://codex.wordpress.org/Moving_WordPress) but when I tried to log back into wordpress I got Error 404.

    So I went back to the forums and found that this happens a lot. I looked through the tutorials and found one on changing your URLs manually (http://codex.wordpress.org/Changing_The_Site_URL) to get back into the admin panel. I tried this and got error message 500.

    I had downloaded the site before I started making changes in case something like this happened and attempted to upload the original site (before all the URL changes were made) but after I uploaded it I'm still getting Error 404.

    I know I have done something simple and stupid but I haven't a clue where to start.

    Please tell me I haven't wiped the full site.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    First. restore everything back to a original sub-directory installation. Then see Giving_WordPress_Its_Own_Directory.

  3. element art
    Member
    Posted 2 years ago #

    Thanks for the quick feedback!

    I've restored everything but I'm still getting the Error 404: File Not Found message so I can't access the admin panel.

    Any other suggestions?

    Many Thanks

  4. element art
    Member
    Posted 2 years ago #

    I am still none the wiser about this - Is there anyone who can provide help get this site live?

  5. So if WordPress is installed in the wordpress directory you should be able to login to your site at http://example.org/wordpress/wp-login.php. If when you login you get redirected to http://example.org/wp-admin with a 404 error then you need to follow the instructions on manually changing the site url http://codex.wordpress.org/Changing_The_Site_URL

    Or you can add the following to wp-config.php

    define('WP_SITEURL','http://example.com/wordpress');
    define('WP_HOME','http://example.com/wordpress');

    Once your back in follow the instructions for Giving WordPress It's own directory:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    If you need immediate help please come to the WordPress IRC channel and we will be able to help you step by step. http://codex.wordpress.org/IRC

  6. element art
    Member
    Posted 2 years ago #

    Thanks Chris,

    I'll try all these now and get back to you in the link above if I run into problems.

    Your help is very much appreciated!

  7. element art
    Member
    Posted 2 years ago #

    Hi Chris,

    I managed to change the URL back to the original and access the admin panel again but when I get back into the general panel I can't change the URL - it is in a dark grey colour and I can't select it.

    Thanks

    [No bumping. If it's that urgent, consider hiring someone.]

  8. The option is greyed out because it is being overridden in your wp-config.php file. Stay on the option page remove the lines you inserted into wp-config.php refresh the page and you will be able to change the options again.

  9. element art
    Member
    Posted 2 years ago #

    Thanks Chris

    I'll give that a go...

  10. element art
    Member
    Posted 2 years ago #

    Didn't work :( I know I'm doing something wrong but I'm not sure what...

    I stayed on the general options page
    Opened the wp-config.php file
    Deleted the 2 lines of code
    Refreshed the general options page
    and got error 404 file not found.

    One of the guys in the wordpress chat suggested removing the htaccess file but I can't find this.

  11. Krishnendu.vp
    Member
    Posted 2 years ago #

    Kindly follow the below steps to move the wordpress installed directory to another directory:

    For example if we need to move the wordpress installed directory to public_html i.e., http://domainname.com/wp to http://domainname.com/

    • Login to the cPanel of the user
    • Take a backup of the domain
    • Move the entire files in public_html to a new folder, say “Main Site”
    • Now copy the entire files inside wordpress directory to public_html
    • Take the phpMyAdmin
    • Select the user’s wordpress database->wp-options -> Change the site url and home url to http://domainname.com/ from http://domainname.com/wp
    • Now edit the .htaccess as follows in public_html:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase / (/ represents public_html directory)
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L] (Since index.php is located in public_html)
    </IfModule>
    # END WordPress

    • If the images are not loading correctly in site, do the below steps:

     Take the phpMyAdmin -> Export the user’s database
     Create a copy of the downloaded SQL file and open in word, then find and replace the content “domainname/wp” to “domainname/”
     Take the phpMyAdmin and drop all the tables in user’s database and upload the edited SQL file

    Now check the site.

  12. element art
    Member
    Posted 2 years ago #

    Many Thanks for all your help with this.

    I managed to get the site back up and live. I went back to the start and using a combination of all the methods and links given to me I managed to rename the URL in the general settings panel.

    I then moved all "live" files in a new directory via FTP. Finally I moved all the files from the subdirectory (www.mysite.com/wordpress) into the main directory (www.mysite.com/wordpress)

    Then I went back into the wp-config.php file and removed the code.
    define('WP_SITEURL','http://example.com/wordpress');
    define('WP_HOME','http://example.com/wordpress');

    The site went live but there are just 2 small glitches left
    1. When I click the Home button it brings me back to the original path (www.mysite.com/wordpress) where there are no longer any files. All other links are working fine though.

    2. I've uploaded 2 images but they are showing up as broken links.

    Is there a way of making sure all the paths for links, images, video etc.. link back to the main directory from now on? Do I need to start a new thread for this?

    Thanks
    Grace

  13. element art
    Member
    Posted 2 years ago #

    Many Thanks for all your help with this. I'm delighted with the help and feedback given.

    I managed to get the site back up and live. :) I went back to the start and using a combination of all the methods and links given to me I managed to rename the URL in the general settings panel.

    I then moved all "live" files in a new directory via FTP. Finally I moved all the files from the subdirectory (www.mysite.com/wordpress) into the main directory (www.mysite.com/wordpress)

    Then I went back into the wp-config.php file and removed the code.
    define('WP_SITEURL','http://example.com/wordpress');
    define('WP_HOME','http://example.com/wordpress');

    The site went live but there are just 2 small glitches left
    1. When I click the Home button it brings me back to the original path (www.mysite.com/wordpress) where there are no longer any files. All other links are working fine though.

    2. I've uploaded 2 images but they are showing up as broken links.

    Is there a way of making sure all the paths for links, images, video etc.. link back to the main directory from now on? Do I need to start a new thread for this?

    Thanks

  14. element art
    Member
    Posted 2 years ago #

    I managed to figure this out with a little trial and error. I went to the Menu panel and clicked into the Home tab - I could change the URL here directly.

    Thanks again for all your help!!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic