WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Problem with WPML (4 posts)

  1. Matt
    Member
    Posted 1 year ago #

    I am using the WPML plugin (for translations). Something is preventing me from doing the translation by clicking the normal link to do it. I have tried adding this:

    RewriteCond %{REQUEST_URI} ^/wp-admin/admin.php?page=wpml-translation-management/ [NC]
    RewriteRule . - [S=2]

    but that doesn't seem to help. This is what the URL looks like that I am trying to go to:

    mysite.com/wp-admin/admin.php?page=wpml-translation-management/menu/translations-queue.php&icl_tm_action=create_job&iclpost[]=933&translate_to[de]=1&iclnonce=9b2aebd112

    Any ideas?

    WP Version: 3.4.2
    BulletProof Security Version: .47.6 (wasn't sure about updating until after I upgrade to WP 3.5)

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. Matt
    Member
    Posted 1 year ago #

    Looks like I got it figured out by adding this in the wp-admin/.htaccess file:

    #For WPML Translations
    RewriteCond %{QUERY_STRING} page=wpml-translation-management/menu/translations-queue.php(.*) [NC]
    RewriteRule . - [S=2]

    Does that seem about right?

  3. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Yep you got it right! Looks good to me. Well done.

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    And actually you should upgrade to BPS .47.7 before you upgrade to WP 3.5. There is bug fix in .47.7 for WP 3.5. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic