WordPress.org

Ready to get started?Download WordPress

Forums

Problem with wp-includes/category-template.php (2 posts)

  1. jimliston
    Member
    Posted 1 year ago #

    I tried to edit the category-template.php file to change the tag cloud function on line 523. All I changed was the numbers of:
    'largest' and 'number'
    'smallest' => 8, 'largest' => 22, 'unit' => 'pt', 'number' => 45,

    Now I get the error message:
    Parse error: syntax error, unexpected '<' in /public_html/wp-includes/category-template.php on line 676

    When I tried to use my backup file, I still get the same error message.
    Is there something I can do or is there a way to get a clean copy of the category-template.php file?

    Thanks,sorry for the double post, I couldn't figure out how to remove the other post.
    Jim

    Update, I added a new copy of category-template.php and now I get the error message:

    Fatal error: Only variables can be passed by reference in /public_html/wp-includes/category-template.php on line 675

    Here is line 675:
    str_replace( ',', ',',','.', ( $smallest + ( ( $count - $min_count ) * $font_step ) ) )

  2. Jonathan Dingman
    Member
    Posted 1 year ago #

    do NOT edit core code.

    Whatever you do, don't do it.

    Always, ALWAYS find a way to do it through a plugin.

    Hacking the core is the worst thing you can do.

Topic Closed

This topic has been closed to new replies.

About this Topic