WordPress.org

Ready to get started?Download WordPress

Forums

WP-FlyBox
[resolved] Problem with WP-FlyBox and Responsive Theme (10 posts)

  1. Arctos WP
    Member
    Posted 1 year ago #

    Hi, I use WP-Flybox 3.7 on my site. It works fine on twenty-twelve, but have a problem with Responsive Theme. It works fine on every page except the mainpage, which is set in template options, not in "static mainpage" tab (I have this tab empty, but if I set something there, FlyBox works fine). I think i could add some code to home.php, but I'm not sure what and where should I add. I find something like that in the source of other page, that works:

    <div id="WP-Flybox at http://njarb.com/2012/08/wp-flybox/" style="display:none;visibility:hidden;"></div><div class="wpfb-facebook" id="wpfb-facebook">
            <div class="wpfb-facebook-transition">
              <table class="wpflyboxtable">
                <tr style="background:transparent"><th style="vertical-align:top"><a href="#"><div style="margin-left:0px; margin-top:0px; width:33px; height:101px; background-position:0px -303px; background-image:url('http://otaku.btorion.pl/wp-content/plugins/wp-flybox/static/FlyBoxSpriteRight.png');padding:0px;"> </div></a></th><th style="background-color:#fff; border: 2px solid #3c95d9;width:292px;overflow:hidden;padding:0px;line-height:0.5"><iframe title="Facebook" src="http://www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Forionotaku&locale=en_GB&width=292&height=500&colorscheme=light&show_faces=true&stream=true&header=false" style="background-color:#ffffff; border:none; overflow:hidden; width:292px; height:500px;">iframes not supported by your browser.</iframe></th></tr>
          </table>
          </div>
          </div>

    but when I add it to home.php (below footer include) it shows the tab on the full screen, without animation.

    What should I do to make it works?

    http://wordpress.org/extend/plugins/wp-flybox/

  2. cconoly
    Member
    Plugin Author

    Posted 1 year ago #

    Where is the "static mainpage" tab?

  3. cconoly
    Member
    Plugin Author

    Posted 1 year ago #

    If you want to manually insert the tabs then there are two things that need to be included. They are the tabs and the stylesheets for the tabs

    Put the following code in your header.php right below <?php wp_head(); ?>:
    <?php include_once('wp-content/plugins/wp-flybox/includes/css.php'); ?>
    and the following right after the <body> tag:
    <?php include_once('wp-content/plugins/wp-flybox/wpflybox_import.php'); ?>

    so that the end result will look like:

    <?php wp_head(); ?>
    <?php include_once('wp-content/plugins/wp-flybox/includes/css.php'); ?>
    </head>
    
    <body <?php body_class(); ?>>
    <?php include_once('wp-content/plugins/wp-flybox/wpflybox_import.php'); ?>

    I did not actually test that this will work, so let me know if it works and if not then I will see what I can do. This will also manually insert it into every page even if it is turned off in WP-Flybox settings. Let me know if you need it to be turned on and off or on specific pages and I can help you to add limiters to the manual code. I am still going to try and figure out why it won't show the right way, but I am unable to produce the same result you had by making the "static mainpage" tab empty because I cannot find that tab?
    Thanks

  4. Arctos WP
    Member
    Posted 1 year ago #

    Hi, as a "static mainpage" i mean: Appearance > Themes > Static Front page. When I set any static page (or "your latest post") as a mainpage, everything works fine. But the default main page of this theme don't work with plugin.

    I will try Your solution with adding the code manually and will write if it helps.

    Thank You!

  5. cconoly
    Member
    Plugin Author

    Posted 1 year ago #

    I tried leaving the mainpage blank and used the themes front page and everything still worked correctly. The only way I was able to make it not show on front page was when I unchecked the "show on front page" option in the WP-Flybox settings. Double check for me and make sure that you have the box checked to show it on the front page in the WP-Flybox settings. Thanks

  6. Arctos WP
    Member
    Posted 1 year ago #

    I think I have it checked, see the printscreen. The page is http://www.otaku.btorion.pl

  7. cconoly
    Member
    Plugin Author

    Posted 1 year ago #

    Oh ok I think I see what might be wrong. I will try and push out an update this afternoon if I can get it fixed. Thanks.

  8. cconoly
    Member
    Plugin Author

    Posted 1 year ago #

    Please update WP-Flybox to version 3.8 for the possible fix. I never could get the same results as you did, but I have an idea of what may have caused it. I issued an update fixing what I think may have been the problem. Try removing the lines of code you added earlier to manually insert it, update to 3.8 and then please let me know if this update fixed it. Thanks!

  9. Arctos WP
    Member
    Posted 1 year ago #

    WOW - fixed! :-D
    Everything works fine now, thank you very much! :)

  10. cconoly
    Member
    Plugin Author

    Posted 1 year ago #

    GREAT! Thanks for the help!

    I am marking this post resolved. Let me know in a new post if you have any other problems.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.