WordPress.org

Ready to get started?Download WordPress

Forums

Problem with wp-cron; Bluehost has suspended my account! (5 posts)

  1. ji737
    Member
    Posted 3 years ago #

    I was just sent an email from Bluehost telling me that they've suspended my site. Calling them, they tell me wp-cron.php is somehow in an unending loop. As I understand it, this can be triggered from the yandex.ru bot or others based on some research I've done. However I am not an expert at this stuff, and at the moment since Bluehost has suspended the account, I can't access the wp-admin page to do any exploratory surgery on my dashboard. I can access all of the files on my server but it isn't like I know what to look at or do to see what is causing the problem. I have been having some serious site performance issues (2 or 3 minutes to load any of the pages, occasional 500 errors, more often "Cannot connect to database" errors) but now it's been taken down. What can I do to make it all work again? Many thanks if anyone can help. I'm not aware that I've done any changes within the site that would do this, mainly because I wouldn't know how.

    This is the error message that bluehost sent me when I inquired:
    inawildf 2310 7.0 2.7 582708 449544 ? SN 11:42 0:13 | \_ /ramdisk/bin/php5 CONTENT_LENGTH=0 CONTENT_TYPE=application/x-www-form-urlencoded DOCUMENT_ROOT=/home1/inawildf/public_html GATEWAY_INTERFACE=CGI/1.1 HTTP_ACCEPT=*/* HTTP_ACCEPT_ENCODING=deflate;q=1.0, compress;q=0.5 HTTP_HOST=www.inawildflower.com HTTP_USER_AGENT=WordPress/3.0.1; http://www.inawildflower.com PATH=/bin:/usr/bin QUERY_STRING=doing_wp_cron REDIRECT_STATUS=200 REMOTE_ADDR=69.89.31.156 REMOTE_PORT=45708 REQUEST_METHOD=POST REQUEST_URI=/wp-cron.php?doing_wp_cron script _FILENAME=/home1/inawildf/public_html/wp-cron.php script _NAME=/wp-cron.php SERVER_ADDR=69.89.31.156 SERVER_ADMIN=webmaster@inawildflower.com SERVER_NAME=www.inawildflower.com SERVER_PORT=80 SERVER_PROTOCOL=HTTP/1.0 SERVER_SIGNATURE=<address>Apache Server at www.inawildflower.com Port 80</address>? SERVER_SOFTWARE=Apache UNIQUE_ID=TNLwgkVZH5wAAAZcGGcAAACW file_gzip=/ramdisk/cpud/status PHPRC=/home1/inawildf/public_html/:/etc/:/usr/local/lib/

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  3. bh_WP_fan
    Member
    Posted 3 years ago #

    Everything suggested by esmi is essential.

    In addition to that, you may want to optimize your database:

    1. Log into your cpanel.
    2. Click on phpMyAdmin.
    3. On the left will be a list of your databases. Select the one to repair/optimize.
    4. This will load all of the tables in your database into the right side. At the bottom of this list, check the "Check All" checkbox.
    5. Just to the right of the Check All link, select the "Repair" option in the drop-down list.
    6. This will list all the tables, with "OK" listed next to them. When this is done, look up to the top of the page and click on the "Structure" tab.
    7. This will take you back to the page you saw on step 4.
    8. Click "Check All" again, and then choose "Optimize" in the drop down menu.

    Since your site will probably be offline currently, you can change your WordPress theme to twentyten via PHPMyAdmin. See: http://wordpress.shadowlantern.com/how-change-wordpress-url-phpmyadmin/

    You will also want to browse the content of your php files and make sure you haven't been hacked. If you are worried about this possibility, but don't understand how to check it, you may want to re-upload all the default WordPress files.

  4. ji737
    Member
    Posted 3 years ago #

    Thank you both for your replies.

    Bluehost reactivated my site and I deactivated all of my plugins. I have done all of the steps recommended by bh_WP_fan on all databases. At the moment they have not yet deactivated it again, however I am still experiencing the same slow-as-molasses page loading (even pages with no images, or simply pages within my wordpress dashboard) and occasional 500 error messages that I think eventually was the root of my site being deactivated by Bluehost.

    I am currently running the ProPhoto 3 theme. I would try switching over to the Twenty Ten theme just to see if it is ProPhoto that is causing the problem, but as that theme seems to be the backbone of everything on my site, I'm worried that if I switch over to a different theme, I run the risk of losing my site (content, formatting, appearance, I'm not sure if any, all, or none of that will be affected by switching to Twenty Ten and back to ProPhoto). Can I switch over with no risk, to see if it is the theme causing the problem?

    If it is not a problem with the theme, I will attempt to re-upload the default WordPress files as recommended. In specific, which files are these (the wp-.php files? All of them, or just some)?

    Thanks for any help. This is driving me nuts.

  5. bh_WP_fan
    Member
    Posted 3 years ago #

    To re-upload the WordPress core files, simply follow the upload instructions from the upgrade instructions as if you were going to upgrade your site: http://codex.wordpress.org/Upgrading_WordPress

    To assist in optimizing your site, see the following: http://wordpress.shadowlantern.com/2009/01/reducing-cpu/

Topic Closed

This topic has been closed to new replies.

About this Topic