WordPress.org

Ready to get started?Download WordPress

Forums

problem with wordpress on an university server (8 posts)

  1. jbb06
    Member
    Posted 5 years ago #

    Hi, I have a problem!
    I tried to install wordpress on my university server (where I have my website - I want to add a blog), but it doesn't work.
    I installed the wordpress directory in a new directory, but when I want to launch the "install" file, I just have one message to open or save the install.php file :( !!!

    I was very carefully with the installation steps:
    I created a SQL database on Freehostia, and I change the information about the database in the wordpress config file. I think the information about the database are good, because when I try to create wordpress blog on another server with the same config file (like a freehostia one), it works!

    Maybe should I ask something special to the people who are taking care about the university server for my installation works, but what exactly ??

    Does anyone have an idea !?
    Thank you so much,
    jo

  2. vteixeira
    Member
    Posted 5 years ago #

    does your university server supports php?
    What version is the php?
    The server is windows or linux?

  3. jbb06
    Member
    Posted 5 years ago #

    Thanks!
    Now php is installed, the page is launched, but there is a message that there is no connexion with the database... (despite it works on an other website)

    Could it be because of the MySQL version on the server ?

    Thanks,
    Jo

  4. sweetangst
    Member
    Posted 5 years ago #

    ... Naturally your blog on Freehostia would work with the database on Freehostia...

    The question is does your config file at the university blog SPECIFY where to find your database?

    E.g. The config.php file by default looks for your database at the localhost (in your case, the school's network) but you have your database elsewhere... thus you must specify in the config file where your's is.

  5. sweetangst
    Member
    Posted 5 years ago #

    From here: http://forum.freehostia.com/viewtopic.php?t=240

    Once you have created a database you can setup your scripts to connect to it using the following settings:
    database name: username_db1 (the whole name of the database - the one that you see in the Manage SQL Databases section of your web hosting control panel)
    database username: username_db1 (the same as above)
    database password: password (the password that you have set to your database - you can edit it from the Manage SQL Databases section)
    database host: server.com (server.com is an example, you can see the correct server name / database hostname in the Manage SQL Databases section, just under the table with the list of your database(s))
    database port: 3306

  6. jbb06
    Member
    Posted 5 years ago #

    Thanks for your answer sweetangst!
    The thing is that:
    I already wrote all these information in my wp-config file.
    I even verified that the wp-config file is the same if I install successfully wordpress on my freehostia website.

    But I still have the database connexion error message :-(
    So I am wondering if it could be because of the mySQL version on the school server.

    If anyone has an idea...
    Jo

  7. sweetangst
    Member
    Posted 5 years ago #

    I would ask the university if wordpress / blogs are allowed in general. I know that my old university had several blocks in place so that you could not host a blog there.

  8. ryans149
    Member
    Posted 5 years ago #

    One silly question, are your files and database on the same server???

    If yes, then use the database server as localhost.

    if not, then also you can use that database. You need to use the IP address of the database server instead of localhost. But in this case, database server must allow remote connection..

    Just check this out..

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.