WordPress.org

Ready to get started?Download WordPress

Forums

problem with wordpress 2.7 and error in my blog (4 posts)

  1. manuelanorga
    Member
    Posted 5 years ago #

    I was in my FTP and delete some important files like wp-config.php in the wp-content. Fortunately I have all my uploads and i have my mysql pass.. no problem with that.

    I tried to install the wordpress 2.7 with my keys host in my wp-config and got this error:

    Warning: array_keys () [function.array-keys]: The first argument should be an array in / home / murs / public_html / wp-includes / widgets.php on line 1044

    Fatal error: Call to undefined function wp_remote_request () in / home / murs / public_html / wp-includes / update.php on line 58

    I am doing a backup in my pc with the wp-content, and wp-admin wp-includes. I have to delete my files to re-install everything??? .

    Please, I need some help.... what i have to do?

    sorry for my english..

  2. dGudaitis
    Member
    Posted 5 years ago #

    Try uploading the files again. Some information probably got lost when FTPing.
    I had the same problem with update.php and fixed it by uploading and overwriting just the core files in the root (not wp-admin, wp-content, and wp-include directories).

  3. marylutz
    Member
    Posted 5 years ago #

    I did this

    Try uploading the files again. Some information probably got lost when FTPing.
    I had the same problem with update.php and fixed it by uploading and overwriting just the core files in the root (not wp-admin, wp-content, and wp-include directories).

    And still getting this error: Fatal error: Call to undefined function wp_remote_request() in /home/provbsco/public_html/wp-includes/update.php on line 58.
    Please help. Thanks!

  4. nathaliepelletier
    Member
    Posted 5 years ago #

    hi
    i had this same error code:
    Warning: array_keys() [function.array-keys]: The first argument should be an array in [mysiteaddress]/wp-includes/widgets.php on line 1044

    here's how i fixed it:
    1.went to my cpanel
    2.then to myphpadmin (i'd never altered this, so i was a bit apprehensive...but it worked)
    3.on the left side list i found my wordpress data base & clicked it
    4.with new choices on left side, i found wp_options,clicked once
    5.in main window, clicked the browse tab, and looked for widget_text (there are many pages to choose from,so if you don't see it immed.just use the dropdown menu to select the next page)
    6.once you find the line with widget_text, hit the edit button (mine looks like a pencil)
    7.when the new window pops up, you will notice a box with text that you added for the widgets. Delete all of the text in the box.
    8.you will see a box underneath, that gives the option to save,then press go.
    9.now a new page shows you the code which has been altered. you will notice at the very end of the sql code it says something like text=1, change it to a higher number to avoid this same prob in the future.
    10.press save again
    11.done

    i hope this helps!

Topic Closed

This topic has been closed to new replies.

About this Topic