WordPress.org

Ready to get started?Download WordPress

Forums

Problem with Windows Live Writer (7 posts)

  1. Snat
    Member
    Posted 4 years ago #

    Hey,

    First of all, this is "possibly" a issue only Microsoft can deal with but I thought I would first try the lovely support here.

    I use Windows Live Writer to post articles on my blog (at http://snat.co.uk). However when I try to edit a post using it, I am only able to view the last 100 articles on there. The problem is I am trying to edit an article older then that and when I do, WLW just loves to throw the following error at me.

    The response to the metaWeblog.getRecentPosts method received from the blog server was invalid:
    
    Invalid response document returned from XmlRpc server

    Now, I looked in the error log and the only thing I could find that was basically something that looked wrong was:

    <b>Fatal error</b>:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 198090 bytes) in <b>/home/XXXXXXXXXXXXXXXX/public_html/wp-includes/class-IXR.php</b> on line <b>97</b><br />
    <br />","
    
    WindowsLiveWriter,2224,None,00007,07-Feb-2010 23:28:52.073,"DisplayableException occurred: WindowsLive.Writer.Extensibility.BlogClient.BlogClientInvalidServerResponseException: Invalid Server Response - The response to the metaWeblog.getRecentPosts method received from the blog server was invalid:

    Would I be correct in guessing that this is possibly just a memory issue or is it something else ?

  2. Chris_K
    Member
    Posted 4 years ago #

    I'm just spit-balling here... but one might almost guess that your host (PHP) is where the memory exhaustion is happening. If so, try one of these standard responses:

    methods for increasing the amount of memory a PHP script may consume

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 16M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

  3. Snat
    Member
    Posted 4 years ago #

    Thanks for your answer, but sadly either of them worked. After further Googl'ing about, I have seen some had this issue on WordPress.com which related to having an odd character in the title of the post.

    I am going to have a look and I am guessing that when I migrated away from qTranslate that I may have left a <! or something in the title that Windows Live Writer may not like.

    Will post back if I find a solution.

  4. MartinOrban
    Member
    Posted 4 years ago #

    Can anybody help me?
    I used to write with WLW at wordpress (got a blog there). Now I got my own URL using wordpress for editing, but i canĀ“t connect with WLW - says cannot find url?

    Thanks
    Martin

  5. pehrsson
    Member
    Posted 3 years ago #

    I had the same problem with Microsoft Live Write.

    To solve it it moved all my postings to the Trash and verified that Live Writer could fetch all postings (none) from the blog without errors. After that I restored one posting at a time and verified that Live Writer could still fetch all postings (if you have many postings you can try restoring more than one between each try). When I restored the LAST posting Live Writer stopped working (Why is it allways the last?). I rewrote the posting and now Live Writer works without any problems.

  6. Digital Raindrops
    Member
    Posted 3 years ago #

    @Martin,

    Admin > Settings > Writing

    On the page there is a section for 'Remote Publishing' with two check boxes.

    I think WLW is XML-RPC, I just check both.

    Then you should be able to connect.

    HTH

    David

    DUH!
    just see how long ago martin posted, and I spent good time checking the names of the checkboxes.

    pehrsson: why reply to a six month old post??

    WordPress: why not 'batch auto lock' topics with no more replies after a month?

  7. pehrsson
    Member
    Posted 3 years ago #

    I replyed because I had the same problem and didn't find any solution. The next time someone searches for the same error they may find this posting and my solution and maybe make use of it.

Topic Closed

This topic has been closed to new replies.

About this Topic