WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] problem with user and password of polldaddy 0.8 into of wordpress 2.7 (11 posts)

  1. alexoandro
    Member
    Posted 5 years ago #

    Hello :
    I'm installation pooldaddy in wordpress 2.7 but when I activate the plugin in the panel of control of wordpress he(she) says to me above(up) that should put the information of user and password of polldaddy, I put it but it(he,she) does not do anything, and continues asking this information me. In the web of polldaddy if it(he,she) enters(approaches) me with the same information (user and password) since I can solve this to be able to activate the plugin definitively?

  2. dbasulto
    Member
    Posted 5 years ago #

    i have the same problem with polldaddy plugin 0.9 and WP 2.7.1

  3. Beau Lebens
    Member
    Posted 5 years ago #

    This seems to be a problem with the way the plugin uses the new HTTP API in WP 2.7. I replaced lines 137+ in polldaddy.php and it allowed me to authenticate:

    if ( !$polldaddy_api_key || is_wp_error( $polldaddy_api_key ) ) {
    			$this->errors->add( 'polldaddy_password', __( 'Invalid Account' ) );
    			return false;
    		}
    		$polldaddy_api_key = is_array( $polldaddy_api_key ) ? wp_remote_retrieve_body( $polldaddy_api_key ) : $polldaddy_api_key;
    
    		update_option( 'polldaddy_api_key', $polldaddy_api_key );

    Still looking at some other issues, but I'm doing this on WPMU, so YMMV

  4. Paolo T. (pixline)
    Member
    Posted 5 years ago #

    I think there's something wrong with the API. My API key in the option.php view is:

    `
    <?xml version='1.0' encoding='utf-8' ?>
    <pd:pdResponse partnerUserID='0' xmlns:pd='http://api.polldaddy.com/pdapi.xsd'>
    <pd:errors>
    <pd:error id='333'>Invalid Request, 305</pd:error>
    </pd:errors>
    </pd:pdResponse>
    `

    (I hope this is not a valid API key, at least :) The ironic thing is that they just blogged yesterday about WordPress integration, but looking at the code (even trunk) I can see they *at least* forgot one commit, because even the menu icon path is wrong (hardcoded a strange 'wp-content/admin-plugins', which also don't respect the actual URL structure for the blog...)

    This is really bad. I can (barely) accept this kind of errors by a volunteer, non profit plugin author, not from "an Automattic company", come on.. at least test it on a vanilla WordPress before blogging about it!

  5. longwinterfarm
    Member
    Posted 5 years ago #

    Same problem here!

  6. beaulebens - That doesn't work on WP nonMU (just tried)

    Augh, this is really annoying.

  7. tcsoul
    Member
    Posted 5 years ago #

    *sigh*

    Same problem here.... surprising to see coming from anything with the "Automattic" name on it.

    Polldaddy 0.9 & WP 2.7.1

  8. I submitted a trouble ticket through PollDaddy on this one.

  9. JUST got a reply from PollDaddy:

    we are aware of this issue and we are working on a fix.. we hope to have an updated and working plugin very soon.. sorry for the inconvenience.

    From Eoin

    Thank you! I was all excited to have this >.<

  10. tcsoul
    Member
    Posted 5 years ago #

    Ipstenu - thanks for the update!!

  11. Michael Adams (mdawaffe)
    Member
    Posted 5 years ago #

    Eoin and I have updated the plugin to version 1.0. It fixes all known bugs. Please upgrade. If things still don't work for you, please let PollDaddy know:

    http://www.polldaddy.com/feedback/

    or tell us here on these forums:

    http://wordpress.org/tags/polldaddy?forum_id=10#postform

Topic Closed

This topic has been closed to new replies.

About this Topic