WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] problem with URL (11 posts)

  1. bakercake1
    Member
    Posted 4 years ago #

    My domain name is bakerthebrand.com

    For some reason when I type this in as a regular url search I am automatically getting: "what-succesful-bloggers-are-saying-about-bakers-world-blog" automatically attatched to my URL

    resulting in a 404 page error. I tried going on
    Setting>Reading but that URL is not saved as a "static page"

    Please help! I would like to get it back to my regular URL working normally.

    Thank you!!

    Baker

  2. wprelief
    Member
    Posted 4 years ago #

    Do you have a "page" in WordPress that has this as the title or slug for the page?

    If you have unpublished or deleted the page that had this url, then you need to (re)publish this page.

    If I have misunderstood, please add a link or more information so that I can understand.

  3. bakercake1
    Member
    Posted 4 years ago #

    Yes this is correct, I created a "page" for this with just the title and had deleted it.

    How do I go about (re)publishing this page?

    Should I just take the old title as:

    what-succesful-bloggers-are-saying-about-bakers-world-blog"

    on the title and post it under a new page and hit publish?

    Thanks

  4. wprelief
    Member
    Posted 4 years ago #

    You may check your "trash" to see if the page is still available. If not, then you will need to create a new page and make sure the slug is the same as the link you are trying to retrieve. If it is there, just republish it!

  5. bakercake1
    Member
    Posted 4 years ago #

    Hello,

    The trash is empty.

    However, I did republish it with the correct slug as a new page, but the URL still directs me to this: http://bakerthebrand.com/what-succesful-bloggers-are-saying-about-bakers-world-blog

    Not sure what I'm missing...

    Thanks

  6. bakercake1
    Member
    Posted 4 years ago #

    Just to clarify I'd like my normal URL to be back to: http://www.bakerthebrand.com

    withought the extra slug at the end that automatically is directing it to an Error 404 page...

    I'm sure its just a small thing I'm not seeing that will get it back to the normal url....

  7. wprelief
    Member
    Posted 4 years ago #

    I think that I understand you to be saying that you are looking to make a page your homepage instead of having your listed out posts on your homepage.

    To do this, go to Settings >> Reading and choose "A static page" radio, then choose your page from the drop down. Save.

    This will set this page as your homepage.

  8. bakercake1
    Member
    Posted 4 years ago #

    Hello
    I think my question is a lot easier than I'm presenting.
    I would like my homepage to just go back to regular having my URl link bakerthebrand.com and having the latest posts set up normally.

    if you do a normal url search on my site and type in: bakertherand.com

    that slug in the end is still automatically being added. I tried republishing the exact slug as a 'page,' but that didn't work....

  9. wprelief
    Member
    Posted 4 years ago #

    If you want the homepage to go back to the normal setup, just choose the "Your latest posts" radio and save from the Settings >> Reading in your WP admin.

    As far as the search, I am sorry I so to understand what you are explaining.

  10. bakercake1
    Member
    Posted 4 years ago #

    It is okay, I got it fixed. thank you for your assistance

  11. Duckie777
    Member
    Posted 4 years ago #

    I have this problem as well; I've tried everything above and am stumped...

    I created a static page with the following url:
    http://cheekylit.com/resources/web-2-0-tools/blog-wiki-forum-tools/

    After I created the page, when I enter my site url it 'redirects' to the url above instead. My site url is...
    http://cheekylit.com

    In my General Settings, the wordpress url and site url is correctly indicated for both as...
    http://cheekylit.com

    In my Settings>Reading, it is correctly indicated to show my latest posts in summary form.

    If I trash the new page, I get a 404 message 'not found' for my homepage.

    I don't know what else to do, so if anyone knows what's happening here, advice/instructions would be GREATLY appreciated!!!

Topic Closed

This topic has been closed to new replies.

About this Topic