WordPress.org

Ready to get started?Download WordPress

Forums

Problem with URL (9 posts)

  1. IanEltringham
    Member
    Posted 6 years ago #

    I have a strange problem on my blog, which is only affecting th wp-adim areas. I'm using 2.3.1.

    I changed Blog URL and WordPress URL to http://www.mysite.com. I just wanted to include the www in my domain.

    The problem is after I changed the URL's a couple of hours later I cannot publish or edit posts, add categories etc and when I click the sign out link I'm taken to the dashboard.

    I noticed that the address in the browser when in the wp-admin area was now showing without the www.

    The blog itself remained visible and intact.

    Would adding:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^mysite\.com$ [NC]
    RewriteRule ^(.*)$ http://www.mysite.com/$1 [R=301,L]

    into the .htaccess solve the problem or make it worse.

    Also in a possibly unrelated issue I noticed google has started indexing my posts but has not indexed the home page.

    Anyone got any ideas.

  2. IanEltringham
    Member
    Posted 6 years ago #

    Just an update.

    I'm not getting any errors when using firefox, ie I can manage posts and categories and sign out ok but I am getting these problems with IE7.

    The wp-admin url is showing with www and without at what looks like random in Firefox.

    This is way over may head :(

  3. spoole
    Member
    Posted 6 years ago #

    You didn't say where you changed the urls: was it just in the General Options panel? Try putting these lines in your wp-config.php after the define('DB_HOST' line:

    define('WP_HOME', 'http://www.yoursite.com');
    define('WP_SITEURL', 'http://www.yoursite.com');

    Does that help? Also, I presume you are not using any www-redirect plugin or something like that?

    Also, did you flush your IE7 cache? ;)

  4. IanEltringham
    Member
    Posted 6 years ago #

    Yes in general options.

    I cleared IE7 cache

    and added those two lines you suggested to config.php.

    Didn't help I'm afraid :(

    I'm also having problems with Firefox now.

  5. IanEltringham
    Member
    Posted 6 years ago #

    Changed to these settings in general options

    WordPress address (URL):http://mysite.com
    Blog address (URL): http://www.mysite.com

    This seems to stop the errors when posting, adding categories etc and loging out.

    But, what effect would this have. I'm not sure I understand the correlation between the two.

    Do they both need to be set at the same settings in this situation.

    What will/could happen if I leave them the way they are now.

  6. spoole
    Member
    Posted 6 years ago #

    They should be exactly the same unless your WordPress installation lives in a separate folder ie not in your site root. If the wp-config edit didn't work I don't have any more ideas as to why you're having trouble. :(

  7. IanEltringham
    Member
    Posted 6 years ago #

    Thanks for your help anyway spoole.

    Panicks over a little for me now as I can at least manage posts and categories in IE7 in I change the url in the browser to www when I login.

    Still can't logout though.

    Changing the www in the browser using Firefox make everything work perfectly.

    What I'm noticing is the setting the Blog URL to http://www.mysite.com has has been fine.

    But setting the WordPress URL to http://www.mysite.com has caused me all the problems.

    The url is not being redirected in wp-admin areas, and like I said changing the url in the browser to www gets things working again in Firefox.

    Still, I hate it when somethings not working as it should, and hate it more when I don't understand the problem.

    I'm also wondering if this could have anything to do with my home page not getting indexed in google, even though other pages have been indexed.

    If anyone has any ideas please I would really appreciate any advice you could give.

    Thanks, and thanks again to spoole for taking the time to help.

  8. spoole
    Member
    Posted 6 years ago #

    No problem - just remembered: try the WWW-redirect plugin to force things to be as you want them. (I use it on one of my sites to force no-www, but you can do it your way too.)

    You might have to wait a little while until the behaviour becomes consistent since DNS caches around the internet might have to catch up.

    If google had previously indexed your site as no-www, I believe it will have to gradually reindex the entire thing now it's www. You can use the Google Sitemaps plugin to help with that.

    Good luck!

  9. IanEltringham
    Member
    Posted 6 years ago #

    Nah, I've been getting indexed with WWW, thats why I don't want to go back without.

    Checking out the WWW plugin now.

    Thanks again.

    -------------------
    Update

    www-redirect plugin not going to work either

    I'm stumped :(

Topic Closed

This topic has been closed to new replies.

About this Topic