WordPress.org

Ready to get started?Download WordPress

Forums

Problem with uploads (10 posts)

  1. krs1
    Member
    Posted 7 years ago #

    All the threads I've read don't seem to help on my particular problem.

    I've not been able to use my upload function in wordpress.
    My permissions are wp-content: 777 and my directory uploads: 777.
    I changed these permissions on my server control panel.

    here is the error I get: -

    'The uploaded file could not be moved to /home/mysite/public_html/wp-content/uploads.
    Warning: Cannot modify header information - headers already sent by (output started at /home/mysite/public_html/wp-admin/admin-functions.php:1879) in /home/mysite/public_html/wp-includes/functions.php on line 1219'

    --

    many thanks.

  2. krs1
    Member
    Posted 7 years ago #

    I realise the topic is suspiciously like a thousand others but let me assure you this is not a simple rights issue.
    I've re-installed wordpress 2.1.3 and still the same error?
    Any advice?
    Cheers.

  3. MichaelH
    Member
    Posted 7 years ago #

    I'd agree that permissions are not the problem but rather 'white space' in a script file.

    See: How do I solve the Headers already sent warning problem?

  4. krs1
    Member
    Posted 7 years ago #

    After my initial searches I cleared any 'white space' in the relevant php files but still the same error. I'm starting to think it could be a server issue?

  5. krs1
    Member
    Posted 7 years ago #

    wp_die( printf( __('The uploaded file could not be moved to %s.' ), $uploads['path'] ));

    the above line seems to be where the trouble starts?

  6. therapyindex
    Member
    Posted 7 years ago #

    I have exactly the same problem and have double checked that there are no characters before or after the code.

  7. krs1
    Member
    Posted 7 years ago #

    Any clues on this problem? Could it be a server issue?
    Cheers.

  8. krs1
    Member
    Posted 7 years ago #

    sorry for the bump, can anyone on the afternoon shift help?

  9. krs1
    Member
    Posted 7 years ago #

    up we go

  10. therapyindex
    Member
    Posted 7 years ago #

    I have finally resolved this problem! My host offers the option of running in PHP4 FastCGI mode. They say "This provides a more secure method of running PHP4 programs and has the added benefit that no special measures are needed in order to grant write access to your webspace for PHP scripts."

    I selected this option and now, without doing anything else like CHMOD, I can upload images!

Topic Closed

This topic has been closed to new replies.

About this Topic