WordPress.org

Ready to get started?Download WordPress

Forums

Problem with upload.php (12 posts)

  1. hazyd
    Member
    Posted 10 years ago #

    I am having problems witht the upload function in the 1.2 beta version. Whenever I try to upload an image, it appears to do it, but the image doesn't appear in the folder when I look in ftp and when I try to use the link it creates, it doesn't work either. I get the following error at the top of the results page:
    "Warning: chmod(): Permission denied in /home/hazyd/public_html/wp-admin/upload.php on line 177"
    I have looked in the file at that line, but I can't see what is wrong with it. I have tried it on a couple of installations and get the same error each time.
    Can anyone help?
    Thanks,
    Hazel

  2. mumeimagpie
    Member
    Posted 10 years ago #

    Hey folks,
    I am having a problem very similar to this, but no error message -- I am perplexed and wondering if my installation of Alex King's WP-Photo hack might have smushed the ability to use the original photo functions in WP 1.0.2? The only difference is the lack of error message - the dialog works perfectly, but no file ever appears in the folder on the server.
    I would really appreciate any ideas ya'll might have about this. Thanks in advance! :}

  3. gm2
    Member
    Posted 10 years ago #

    I'm experiencing the exact same problem... Only thing is it WORKED the very first upload I tried and then has failed to work with the above error message every time since.

  4. gm2
    Member
    Posted 10 years ago #

    I figured out what's going on for me anyway! If the file size exceeds the specified threshold on the "Options/Miscellaneous" page, this is the cryptic message that results.

  5. sportbiker
    Member
    Posted 10 years ago #

    same problem here...it seems to upload fine, but the file doesn't appear in the target directory.

  6. mumeimagpie
    Member
    Posted 10 years ago #

    So it sounds like those of us who are uploading fine but not seeing any file in the target directory... are still stuck?

  7. hazyd
    Member
    Posted 10 years ago #

    I solved the problem I was having simply by setting the permissions on the images folder to chmod 777 instead of 766. No errors any more!
    Hazel
    ( who should have read the comments in the script itself and it would have told her to do this - Sorry!)

  8. threefour
    Member
    Posted 10 years ago #

    Besides chmod'ing my images folder to 777, I also removed some spaces that WP seemed to be adding to my directory path in the Options screen.

  9. pappergank
    Member
    Posted 10 years ago #

    I am getting totally frustrated! I am having the same problem with upload.php. Everything looks fine, the page comes back to say that my file uploaded successfully, but when I look in the directory in which it is supposed to have uploaded, it isn't there! I have tried re-uploading a fresh version of the upload.php file...I've chmoded 777 the file and the directory...I can't figure out what is wrong or what else to do. I was working fine before I installed the WP 1.2 Photo Display Hack I installed this hack just fine without any problems on another blog that I have. Did anyone with this problem get it figured out?

  10. carthik
    Member
    Posted 10 years ago #

    Please describe the problem as accurately as possible, and all the things that happen when you try to upload, including error messages if any, and things are different on this particular server, as opposed to the one it worked on.

  11. Anonymous
    Unregistered
    Posted 9 years ago #

    Confirmed - it's clipping files larger than the upload max (Options/Misc), and upload.php is not gracefully handling the error. The PHP tries to chmod the uploaded file, it's not there (error message), then the PHP logic passes on down to where it reports success even though it had just failed.

  12. trench
    Member
    Posted 9 years ago #

    I'm having the same problem. Uploads all of a sudden stoped. I changed the max file size to handle just about any upload but I'm still getting an error message of
    Warning: chmod(): Permission denied in /hsphere/local/home/trench/thetrenchcoat.com/wp-admin/upload.php on line 177
    When I try to upload even the smallest of files. The image directort is chmod to 777.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.