WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce Multilingual - run WooCommerce with WPML
[resolved] Problem with the translation of the URLs (13 posts)

  1. uscarsfrance
    Member
    Posted 1 year ago #

    Hi from France.
    I encounter a problem regarding the translation of some URLs.
    Here is the problem.
    The website is :
    http://www.irotras-productions.fr/
    In the french version, from the menu "Boutique", you have :
    - "Modèle réduit" which links to http://www.irotras-productions.fr/ip.wp/categorie-produit/modele-reduit/
    - "Train réel" which links to http://www.irotras-productions.fr/ip.wp/categorie-produit/train-reel/
    In the english version, from the menu "Shop", you have "Real train" and "Scale model" which point to the same links.
    No problem because I entered the URLs by myself when creating the menus.
    Now, I consider the Woocoomerce widget for "Product categories".
    Since I installed WPML and Woocoommerce Multilingual, it is broken.
    In the french version, it links to :
    http://www.irotras-productions.fr/ip.wp/product-category/XXX/
    ... and in the english version, it links to :
    http://www.irotras-productions.fr/ip.wp/en/product-category/XXX/
    I do not understand how to configure somewhere that it must use "categorie-produit" and not "product-category".
    Thanks for your advices !
    Best regards.

    http://wordpress.org/extend/plugins/woocommerce-multilingual/

  2. David Garcia Watkins
    Member
    Plugin Author

    Posted 1 year ago #

    While I look into this issue, can you confirm that you are running latest versions of everything? At this moment its wpml 2.8.1, wc 2.0.x and woocommerce-multilingual 2.2

    Thanks!

  3. uscarsfrance
    Member
    Posted 1 year ago #

    Hi David.
    Yes, everything is up-to-date : WordPress, Woocommerce, Woocommerce multilingual (2.2) and WPML (2.8.1).
    David, if it can help you to identify the problem, I can give you an admin access to the website without any problem.
    Thanks for your support.

  4. uscarsfrance
    Member
    Posted 1 year ago #

    Hi. I don't understand what is happening. I just added some new translations, clicked on some assistance buttons and now it seems that it works from the widget. So I have to corrected my custom menus to link from "categorie-produit" to "product-category". It's very confusing for me.

  5. David Garcia Watkins
    Member
    Plugin Author

    Posted 1 year ago #

    product-category sounds more like what you should have there. Its the default value. Let me know if you have any other problems here.

  6. uscarsfrance
    Member
    Posted 1 year ago #

    For now, it seems that it is still working. Don't know why it was using "categorie-produit" and not "product-category" before I worked again on my website. I'm going to mark this topic as resolved so.

  7. uscarsfrance
    Member
    Posted 1 year ago #

    Hi. So I installed the last woocommerce multilingual plugin released (v2.3 - development version) and in the same time woocommerce 2.0.9 and my problem with categories from the widget is back. No luck.
    To resume, the URLs which are answering are :
    http://www.irotras-productions.fr/ip.wp/categorie-produit/modele-reduit/
    http://www.irotras-productions.fr/ip.wp/categorie-produit/train-reel/
    http://www.irotras-productions.fr/ip.wp/en/categorie-produit/real-train/
    http://www.irotras-productions.fr/ip.wp/en/categorie-produit/scale-model/
    But the widget for the Product Categories links to for example :
    http://www.irotras-productions.fr/ip.wp/en/product-category/scale-model/
    I really don't know why at a moment, the problem was solved and reappears now again. I've corrected the URLs in the menus to link with "categorie-produit" to help you understand the problem and reach the good pages.
    Thanks for your support !
    Franck

  8. uscarsfrance
    Member
    Posted 1 year ago #

    Is it possible to delete the "Resolved" sign for this post ?

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    You can change the status of any of topic that you started yourself. See the "This topic is" dropdown on the upper right of the topic.

  10. uscarsfrance
    Member
    Posted 1 year ago #

    Done ! Thanks !

  11. David Garcia Watkins
    Member
    Plugin Author

    Posted 1 year ago #

    Could you show me a screenshot of your Settings -> Permalinks screen?

  12. uscarsfrance
    Member
    Posted 1 year ago #

    David, you pointed me in the good direction. I went in settings > permalinks and in the optional section (second one), I had for the product category base "product-category" and for the product tag base "product-tag". But it was written in grey, like a default value which could be replaced. So I rewrited here "product-category" and "product-tag" (in case of potential other issues with tags) and now, the good URLs contains "product-category" and no more this annoying "categorie-produit" that was brocking the product category widget in the sidebar.

  13. David Garcia Watkins
    Member
    Plugin Author

    Posted 1 year ago #

    Great, thanks for the update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.