WordPress.org

Ready to get started?Download WordPress

Forums

Problem with the built-in podcasting functionality (3 posts)

  1. jbickers
    Member
    Posted 6 years ago #

    Having issues with the built-in podcast functionality (i.e., when you include a link to an mp3 file within a post, the properly formed podcast feed identifies it as such). This worked for a while, until we started linking to the mp3 file in multiple places on the same page (once at the top, with a large image to make it easier to find, once at the bottom in a simple text link).

    The podcast software finds the audio when there is just the text link at the bottom; but when there are two references to the audio file, it doesn't see either of them.

    Is there any way around this bug? We really like having the "Click here to listen" image at the top of the post, but the podcast feed doesn't seem to recognize the mp3 file it links to.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    After a post has been processed, you'll notice a custom field on it of "enclosure". The value of this custom field should be three lines:
    Full URL to the file
    Length of the file in bytes
    Content-Type of the file (like "audio/mp3")

    If you manually edit this stuff afterwards, or delete the extra enclosure, then the feed should produce the correct output.

  3. krembo99
    Member
    Posted 6 years ago #

    well.. It was impossiable for me to delete the value , nor the key .
    Not even edit them without the key/value pair popping back to the post.
    I sure was suprised there was no way of disabeling this ...

Topic Closed

This topic has been closed to new replies.

About this Topic