WordPress.org

Ready to get started?Download WordPress

Forums

Leaf
[resolved] [closed] Problem with the arrows back (23 posts)

  1. Sylvain Martineau
    Member
    Posted 1 year ago #

    Hi !

    First, sorry for my English !

    Problem with the arrows back in blog articles... Always have this " %s " before the preceding title...

    Exemple :

    ← %s Pech : Autochtones de la compassion
    Vers une « koalisation » du communautaire!

  2. bradthomas127
    Member
    Theme Author

    Posted 1 year ago #

    @Sylvain Martineau - Looks like the french translation of the theme is messed up. I'll look into it.

  3. Sylvain Martineau
    Member
    Posted 1 year ago #

    I don't have the official french version, but the US version with a translation found on the net...

    http://www.zenbien.com/wordpress-en-anglais-25-fois-plus-rapide-que-la-version-en-francais

    Because according to this guy the official French is slower... But knowing that it is there, I should find the source of the problem (or I'll install the official French version). Thank you again!

  4. Sylvain Martineau
    Member
    Posted 1 year ago #

    And the translation :
    http://www.zenbien.com/wordpress-3-3-1-fichiers-de-traduction-principal-et-theme-francais

    Oops, I just saw that the theme Leaf was also the French file, maybe it comes from there too.

  5. Sylvain Martineau
    Member
    Posted 1 year ago #

    Working now ! thank very much ! ^^

  6. Sylvain Martineau
    Member
    Posted 1 year ago #

    Hello!
    I installed the official French version, but now I have a new problem ... parts are not translated ... here's what I noticed so far:

    CATEGORY ARCHIVES:
    Full Article →

    The link :
    http://pech.great-heberg.eu/wordpress/category/blogue/

  7. Sylvain Martineau
    Member
    Posted 1 year ago #

    Hello!

    It seems that every file included in fr_FR.PO "\ themes \ leaf \ languages​​" is not taken into account.

    Options in wp-config.php define ('WPLANG', 'fr_FR') is present...

    Is there something in particular to enable the translation of a theme ?

  8. Sylvain Martineau
    Member
    Posted 1 year ago #

    In theme-functions.php, I have this line... something to do with my problem ?

    /**
    * Make Leaf available for translation.
    * Translations can be added to the /languages/ directory.
    * If you're building a theme based on Leaf, use a find and replace
    * to change 'leaf' to the name of your theme in all the template files.
    */
    load_theme_textdomain( 'leaf', get_template_directory() . '/languages' );

  9. Sylvain Martineau
    Member
    Posted 1 year ago #

    Hello!

    Problem solved! Just in case, I tried in "Poedit" option "update from a file .POT" (in this theme file), and it has corrected what was wrong!

  10. Sylvain Martineau
    Member
    Posted 1 year ago #

    ... but (arg), now I have the return of the first problem... ^^

    ← %s Pech : Autochtones de la compassion
    Vers une « koalisation » du communautaire! →

  11. AurelBz
    Member
    Posted 1 year ago #

    Hello Sylvain,
    you may find the solution now.
    Otherwise edit the fr_FR.po file and saves.
    We see that there is a not desired "%s" in the translation ...

    #: single.php:21
    msgid "<span class=\"meta-nav\">&larr;</span>"
    msgstr "<span class=\"meta-nav\">&larr;</span> %s "

    Bonjour sylvain,
    tu as peut-être trouver la solution maintenant.
    Sinon avec Poedit édite le fr_FR.po et enregistre.
    On voit qu'il y a un %s en trop dans la traduction ...

  12. Sylvain Martineau
    Member
    Posted 1 year ago #

    Merci infiniment !

  13. Sylvain Martineau
    Member
    Posted 1 year ago #

    It still does not work! I'm getting a bit desperate! The line has been corrected and the% s is still too ...

  14. Sylvain Martineau
    Member
    Posted 1 year ago #

    "Bonjour sylvain,
    tu as peut-être trouver la solution maintenant.
    Sinon avec Poedit édite le fr_FR.po et enregistre.
    On voit qu'il y a un %s en trop dans la traduction ..."

    Pourtant ça avait l'air d'être la solution... Je ne comprends pas...

  15. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    These are English language forums, so please use English. Alternatively, use a WP support forum in your language.

  16. Sylvain Martineau
    Member
    Posted 1 year ago #

    Maybe you can help me ??

  17. AurelBz
    Member
    Posted 1 year ago #

    Hi Sylvain,
    have you used Poedit ?
    Have you copy the .mo file too ?

  18. Sylvain Martineau
    Member
    Posted 1 year ago #

    Yes !

    I just repeat the operation in any case ... But the translation is well interfere somewhere if it works well in English. But on the other hand it should not be interfered, since there is no text, just an arrow.

    P.S. sorry my english not very good...

  19. AurelBz
    Member
    Posted 1 year ago #

    I've read your .po file here :
    http://pech.great-heberg.eu/wordpress/
    It seems to be ok, and no "%s" in navigation
    (?)

  20. Sylvain Martineau
    Member
    Posted 1 year ago #

    Right! Sorry, I also problems with the cache since this morning. Sometimes it can take up to 1 hour before to see the change (even emptying the cache (F5 or Ctrl-F5). Suddenly, this change will just appear ... (see my post here : http://www.wordpress-fr.net/support/sujet-79239-gros-probleme-cache )

    But it works, that's what counts!

    Again thank you for your help.

  21. siriuslunique
    Member
    Posted 7 months ago #

    Sylvain, bonjour.

    Moi-même ayant crée un site WordPress il y a quelques mois avec le même thème que le votre, je me permets de vous répondre.

    J'ai eu depuis le début le même problème que vous : le site était en Anglais alors qu'il y avait bel et bien un fichier de traduction.

    J'ai suivit 2 de vos sujets qui m'ont vraiment beaucoup aidés à traduire mon thème et à supprimer les "%s".

    J'ai visité votre site et j'ai remarqué que votre thème n'était toujours pas en français et que vous n'aviez pas enlevé les "%s".

    Comme j'ai le même thème que vous, je pourrais peut-être si vous le voulez, vous aider à rétablir votre thème.

    Cordialement, Nottin Sirius, via

  22. tizz
    Member
    Posted 7 months ago #

    Not in English, with a job offer, and the user has solved his problem 6 months ago.
    Perhaps it's a bit outside the rules.

  23. esmi
    Theme Diva & Forum Moderator
    Posted 7 months ago #

    @siriuslunique: Please try http://directory.codepoet.com/

    This topic has now been closed as per the Forum Rules.

    @tizz: If you see any posts like this, please just tag the topic with modlook and someone will come along & deal with it asap.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.