WordPress.org

Ready to get started?Download WordPress

Forums

Zotpress
[resolved] Problem with style parameters in 5.0.4. (5 posts)

  1. os2538
    Member
    Posted 1 year ago #

    I have problems with the style parameter in 5.0.4. I'm using the following shortcode:

    [zotpress collection="YXZ" sortby="date" order="desc" style="acm-siggraph" downloadable="no"]

    Regardless of the style parameter I specify in the shortcode or in Options, I always get the same style. I know that "acm-siggraph" is not in the list of styles mentioned on the Zotpress help page, but it's officially supported by Zotero and it worked fine with Zotpress 4.5.4. Furthermore, choosing any other style does not make a difference either.

    On top of that, the downloadable or download parameters do not appear to work with the style that is used.

    Here is the page:

    http://www.informatik.uni-rostock.de/~ostaadt/publications/

    Thanks for your help!

    http://wordpress.org/extend/plugins/zotpress/

  2. Katie
    Member
    Plugin Author

    Posted 1 year ago #

    This should be working -- jQuery is included in the theme -- which means some other issue is at work here. It might be the number of items pulled by this single shortcode. Can you contact me directly? I will likely need to debug on your site. http://katieseaborn.com/contact

  3. os2538
    Member
    Posted 1 year ago #

    I tried it with a smaller collection (only one item instead of the 62 items in the original collection) and it appears to work: the style parameters behave as expected (and as in Version 4.5.4).

  4. Katie
    Member
    Plugin Author

    Posted 1 year ago #

    I think I know what's going on. I'll have to get creative. :) and find some more time. Feel free to contact me to test or watch for a new version within the next week or so.

  5. os2538
    Member
    Posted 1 year ago #

    Works in 5.0.5!
    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.