WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Widget
[resolved] Problem with Social Media Widget and PHP 5.4 (27 posts)

  1. pixelyzed
    Member
    Posted 1 year ago #

    Hi,

    I had a major problem with 4 sites this morning, my 2 sites and 2 of my clients sites. I was getting 500 server errors on the front end but we could navigate the WP admin fine. All sites were on the same host but several other of my clients sites on that same server were not affected.

    After panic driven troubleshooting we realized that Social Media Widget was causing the issue but we didn't know why. I had not updated anything on these sites since last week. But the host had updated PHP on the server to 5.4 sometime last week. I had all sites aggressively cached so that's probably why the problem didn't surface until this morning.

    The thing is, an identical copy of the site on my localhost running PHP 5.3.x runs OK but as soon as I activate SMW 3.3 on the live site it goes down (public side). Same other plugins and theme activated.

    Maybe there's code in your plugin that no longer works with PHP 5.4?

    http://wordpress.org/extend/plugins/social-media-widget/

  2. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    I will investigate this asap, thanks.

  3. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    I just tested on PHP 5.4.1 and did not notice an issue, I'll have to check in 5.4 later. You are on 5.4.0 correct? And you've definitely narrowed it down to SMW?

  4. pixelyzed
    Member
    Posted 1 year ago #

    Hi there!

    No, actually the server is on PHP 5.4.12. Sorry, should have been more specific. So far 2 plugins have caused (different) issues. Yours and Google Analyticator. Yours on the front end, GA in the backend. Both work OK on my PHP 5.3.x localhost.

  5. Oleg Dudkin
    Member
    Posted 1 year ago #

    Same thing here.
    PHP 5.4.12 giving Error 500 on the front end when the plugin is activated.

  6. Oleg Dudkin
    Member
    Posted 1 year ago #

    @pixelyzed,
    What hosting do you use? Seems like it's not a problem with PHP 5.4

  7. profvrr
    Member
    Posted 1 year ago #

    I have also had to disable Social Media Widget on my website http://www.virology.ws as I was receiving 500 server errors. My site runs PHP 5.2.x. Disabling Social Media Widget took care of the issue.

  8. stevecas
    Member
    Posted 1 year ago #

    Problems after update shown here:

    Warning: Invalid argument supplied for foreach() in /home/thewebma/public_html/wp-content/plugins/social-media-widget/social-widget.php on line 463

    Warning: in_array() expects parameter 2 to be array, null given in /home/thewebma/public_html/wp-content/plugins/social-media-widget/social-widget.php on line 467

  9. kgagne
    Member
    Posted 1 year ago #

    I had this same problem on DreamHost, where I'm running PHP 5.3.5. Disabling the plugin or just the widget fixed the problem.

  10. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    For those who received the 500 errors, are you able to check your error logs and send what it says?

    @pixelyzed By any chance are you on Dreamhost as well?

  11. kgagne
    Member
    Posted 1 year ago #

    My server's logs had this to say (though I'm not well-versed in reading such files so hope I am copying the relevant data):

    [Fri Mar 29 07:18:36 2013] [error] [client 218.30.103.148] (70007)The timeout specified has expired: Reading bucket failed (rcode=70007)

    WordPress's debug log said this:

    [28-Mar-2013 14:42:41] PHP Notice: Undefined index: pinterest in /home/kgagne/mschallengeblog/wp-content/plugins/social-media-widget/social-widget.php on line 304

    That error was then repeated for several other social media services (ie, Undefined index: aboutme).

  12. Oleg Dudkin
    Member
    Posted 1 year ago #

    "PHP Notice" error level can't bring site down. Or at least it should not.

  13. Blink Web Effects
    Member
    Plugin Author

    Posted 1 year ago #

    Ken - Could you enable the plugin again for a second, and once you receive the 500 error, remember the time and check your server error logs and paste what you find here? I'm having trouble reproducing the error on my end and want to make sure I have the right error message.

  14. kgagne
    Member
    Posted 1 year ago #

    Blink! I just reenabled the widget, thus bringing down my site. The timestamp on this error from my server log (not the WordPress debug log) matches the time of this experiment:

    [Fri Mar 29 12:54:10 2013] [error] [client 18.189.88.75] (70007)The timeout specified has expired: Reading bucket failed (rcode=70007), referer: http://www.challengeblog.org/

  15. kgagne
    Member
    Posted 1 year ago #

    [duplicate post, please ignore]

  16. Oleg Dudkin
    Member
    Posted 1 year ago #

    Do you use any page speed optimisers? Plugins or hosting options maybe?
    Seems like this error comes from page speed apache module.

  17. kgagne
    Member
    Posted 1 year ago #

    Hi, Oleg —

    I disabled W3 Total Cache on this site awhile back. I still use Google PageSpeed and CloudFlare.

    -Ken

  18. stevecas
    Member
    Posted 1 year ago #

    Its quite clear this problem occurred after the update of the social media widget. Can the developer just please sort it.

  19. Oleg Dudkin
    Member
    Posted 1 year ago #

    Hi, Ken
    Is it possible to disable Google PageSpeed temporarily just to check? It uses apache module that produces the error.

  20. Oleg Dudkin
    Member
    Posted 1 year ago #

    @stevecas
    It can be sorted out easily. But Kens problem looks completely different than yours.

  21. kgagne
    Member
    Posted 1 year ago #

    Oleg: Disabling PageSpeed appears to have corrected the issue.

    http://www.challengeblog.org/

    However, I have PageSpeed enabled on multiple domains. If there is a way on the Social Media Widget's end that this Google feature can be accommodated, I would be most appreciative.

    -Ken

  22. Oleg Dudkin
    Member
    Posted 1 year ago #

    Thanks Ken!
    It is very important to know what is the reason for that error. Now it will be much easier to fix plugin.

  23. pixelyzed
    Member
    Posted 1 year ago #

    Hi everyone!

    Sorry I kind of disappeared after a couple replies but had a very hectic week (to say the least).

    @Oleg Dudkin

    The sites where I was having the 500 server error issues with this plugin is hosted on a ccolleague's dedicated server and the machine is on OVH's services. He doesn't sell hosting services to the general public, just his clients and a few of his collaborators like me.

    Your insight about page speed optimizers makes sense. Aside from a recent upgrade to PHP 5.4 which apparently is not the actual issue, my colleague has also recently added Varnish to speed up the server and reduce load (the sites are all very speedy even without WordPress caching and his server load averages 6%. Yes, six percent). But these changes were done a while ago and not when the 500 issues cropped up.

    It's probably the latest update to the plugin that created the actual issue. Up until this week I was also using WP Super Cache and since these sites are not updated often, the cache was set to purge only once a week. So the problem probably became visible days after it would have happened without WP caching. I'll point my colleague to this thread and maybe he'll have insight.

  24. Oleg Dudkin
    Member
    Posted 1 year ago #

    @pixelyzed
    Can you do the same thing Ken did? I mean enable plugin for a moment and post any errors that occur.

    The only new feature added to plugin code was using output buffer. It do can interfere with caching plugins which use output buffers and custom error handlers.
    It would be great if you will confirm it by checking your error logs. Thanks.

  25. kgagne
    Member
    Posted 1 year ago #

    v4.0 of this plugin appears to run fine on my sites that have PageSpeed enabled.

  26. 3394fr
    Member
    Posted 1 year ago #

    Hello,
    I am having a problem activating my Social Media Widget. I installed this Plug-in widget successfully. The WordPress instructions are then to activate it and select the settings. In order to activate it, I went to "Appearance/Widgets" and then dragged the Social Media icon to the 'Main Sidebar' on the right. After doing this, nothing happened. I expected to be able to activate it and input my URL settings for my various social media accounts- but NADA. Can you please help soon? THanks

  27. kgagne
    Member
    Posted 1 year ago #

    The widget is collapsed by default. Did you expand it so you could see all its options?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.