WordPress.org

Ready to get started?Download WordPress

Forums

Easing Slider "Lite"
[resolved] Problem with Slider After Domain Change (5 posts)

  1. IOIIOOO
    Member
    Posted 8 months ago #

    We are using Easing Slider Lite on a website we developed, and while under development the site was at <domain>.<host>.com but now is at <domain>.com. Typically when we go "live" with a site we use a serialized-data reparing find and replace script found at http://interconnectit.com/products/search-and-replace-for-wordpress-databases/ to prevent plugins and widgets storing serialized data from breaking.

    After updating, though, we get the following error with the slider in both the front-end and on the admin side:

    Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\websites\<domain>\wp-content\plugins\easing-slider\easingsliderlite.php on line 800

    At that point we have to restore the easingsliderlite_slideshow field to repair it, but all of the image references still point to the development domain. We have several slides, so rebuilding the slideshow would be a large task, plus if we just try to "change image" on the existing slides, it overwrites our customized title, description and links.

    Is there any good way to migrate the slider when changing domains?

    http://wordpress.org/plugins/easing-slider/

  2. MatthewRuddy
    Member
    Plugin Author

    Posted 8 months ago #

    Hi @IOIIOOO, the search and replace script should have done the trick, but if not your only real option is to re-add the images manually. Not much else can be done really, unless you want to go into the database options and replace the domains yourself.

    Very sorry about that!

  3. IOIIOOO
    Member
    Posted 8 months ago #

    If I replace the domains directly in database options, the plugin breaks with:

    Warning: Invalid argument supplied for foreach() in C:\inetpub\wwwroot\websites\<domain>\wp-content\plugins\easing-slider\easingsliderlite.php on line 800

    It wouldn't be a big deal replacing the images if it didn't lose the accompanying info (title, description and link) when the image is replaced under "edit slide". Is that a bug?

  4. MatthewRuddy
    Member
    Plugin Author

    Posted 8 months ago #

    The accompanying info wouldn't normally be replaced, but as something internally is going wrong this doesn't appear to be the happening.

    Can you try resetting the plugin in its 'Settings' panel, then re-importing your localhost easingsliderlite_x database values? Leave them as-is: localhost URLs intact. This should work fine, only the images themselves will show as blanks. No PHP errors should be received if all goes accordingly.

    It's possible that in importing the data some sanatization is breaking the serialized data, or something along those lines.

  5. MatthewRuddy
    Member
    Plugin Author

    Posted 7 months ago #

    Hey again, going to mark this as resolved for now but don't hesitate to make contact again if needed :)

Reply

You must log in to post.

About this Plugin

About this Topic