WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Problem with site title (13 posts)

  1. dondre1992
    Member
    Posted 1 year ago #

    WordPress version: 3.5
    WordPress SEO version: 1.3.4.4

    The settings in the WP dashboard is not the same in Google SERP

    This is the settings:

    General Settings

    Site Title : Miller's Pharmacy May Pen

    Tagline : Best Pharmacy May Pen

    In a few words, explain what this site is about.

    WordPress Address (URL) http://millerspharmacymaypen.com

    Site Address (URL) http://millerspharmacymaypen.com

    This is the results in Google:

    Miller's Pharmacy May Pen | Best Pharmacy May PenMiller's ...
    millerspharmacymaypen.com/
    Miller's Pharmacy May Pen. Home · About Us · Contact Us · Our Team ... 2013 Miller's Pharmacy May Pen. ↑. Responsive Theme powered by WordPress.

    Please help

    Thanks

    Don-Andrew

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Emmppp
    Member
    Posted 1 year ago #

    I have the same problem, two titles are stuck together on the pages.
    Basically, the original site title still shows up.

  3. theddavidsons
    Member
    Posted 1 year ago #

    I have the same problem as well when I search for my site on Google.

    The format has become: title/page/sep/sitename/sitename

    Not sure why the sitename is being repeated.

  4. robgolbeck
    Member
    Posted 1 year ago #

    Change the default title tag in your theme's header.php file. It should look like this: <title><?php wp_title(''); ?></title>.

  5. Emmppp
    Member
    Posted 1 year ago #

    Indeed, I guessed it has something to do with the theme. Mine uses a regular "page" as a home.
    It seems a bit tough to fix this with WordPress SEO by Yoast (when I don't have the problem with All in one SEO). Maybe, if I may, it could be something to fix for the next version.

    My title code is pretty long, I have no idea what to replace, may I ask for a little more help ?

    It's like that :

    <title>
    	<?php
    		$prefix = false;
    
    		 if (function_exists('is_tag') && is_tag()) {
    			single_tag_title('Tag Archive for &quot;');
    			echo '&quot; - '; 
    
    			$prefix = true;
    		 } elseif (is_archive()) {
    
    			wp_title(''); echo ' '.__('Archive',EWF_SETUP_THEME_DOMAIN).' - ';
    			$prefix = true;
    
    		 } elseif (is_search()) {
    
    			echo __('Search for', EWF_SETUP_THEME_DOMAIN).' &quot;'.wp_specialchars($s).'&quot; - ';
    			$prefix = true;
    
    		 } elseif (!(is_404()) && (is_single()) || (is_page())) {
    				wp_title(' ');
    				echo '';
    		 } elseif (is_404()) {
    			echo __('Not Found', EWF_SETUP_THEME_DOMAIN).' - ';
    		 }
    
    		 if (is_home()) {
    			bloginfo('name'); echo ' - '; bloginfo('description');
    		 } else {
    		  bloginfo('name');
    		 }
    
    		 if ($paged > 1) {
    			echo ' - page '. $paged;
    		 }
    	?>
    	</title>
  6. Danielle
    Inactive
    Posted 1 year ago #

    General Settings

    Site Title

    is if you don't use a seo plugin than this settings what is the basic of wordpress, that you will see in google. and not only that, this general setting is useful if you do setting the post title settings in yoast.

    Example My title in Yoast is I love wordpress, News and Updates, this is what I set on my homepage (page = hompage)

    In the general settings, the one when you first install wordpress I set only "WordPress"

    In the title post options I set for page Title and sitename parameters
    Now I create a page with as title WordPress Love

    The title and in google you will see this
    Wordpress Love - WordPress

    - WordPress is because I set that one in the general.
    Set also a force title in seo yoast so that you don't see your title twice.

  7. robgolbeck
    Member
    Posted 1 year ago #

    @Emmppp: replace the whole thing. So take out everything between <title> and </title> and put this there instead <?php wp_title(''); ?>

    Alternatively, if you don't want to mess with any code, you can enable "Force rewrite titles" from the plugin settings (I haven't tried this myself). See the plugin FAQ page: http://wordpress.org/extend/plugins/wordpress-seo/faq/

    True, it's a bit trickier than All in One SEO, but overall I like Yoast's plugin better (I've used both). My only complaint with Yoast is the instructions for updating the <title> tag should be in the plugin settings, rather than having to view the FAQs on the plugin download page. I forget this step almost every time I install the plugin on a new site... :)

    @Nashua Indigo: Using the site title and page titles for SEO is fine for keeping things simple, but if you want to do any customization you really need a plugin. Plus you can't add custom meta descriptions without a plugin - which on their own don't do anything for search rankings, but can be incredibly useful for users in deciding whether or not your page has what they're looking for.

  8. theddavidsons
    Member
    Posted 1 year ago #

    I decided to go with the "Force rewrite titles" option. How long does it take until the double titles no longer shows up on Google?

    I'd rather not touch the code. I don't have good experience with doing so.

  9. robgolbeck
    Member
    Posted 1 year ago #

    @theddavidsons: It depends when Google last indexed your site and how frequently you add new content. It should get reindexed within a couple of weeks or so, max (I've heard as many as 6 weeks, but it's never been more than two in my experience).

    If you're set up with Google Webmaster Tools you could try submitting a new sitemap (Optimization -> Sitemaps -> Add sitemap). I've heard sometimes that can work. No guarantees though... Good luck!

  10. Emmppp
    Member
    Posted 1 year ago #

    @theddavidsons: Does your solution to use "Force rewrite titles" works, with no other consequence?
    What does it do to force it? I'm a little afraid of doing something wrong, that would solve one problem while creating another one...

  11. theddavidsons
    Member
    Posted 1 year ago #

    @Emmppp At the moment it appears to do nothing because I don't think Google has re-indexed my site yet. I can't even find posts that I made over the weekend.

    I've been pretty punctual with adding content on my site, a new post every other day at the very latest so I'm hoping that will speed things up.

    I'm going to try when robgolbeck suggested with Google Webmaster Tools when I get home to my desktop. I'll let you know if I have any success.

  12. theddavidsons
    Member
    Posted 1 year ago #

    @Emmppp I can confirm that "Force rewrite titles" works. It just takes a while until Google reindexes everything.

    As for no other consequences, none that I'm aware of. All I know is that I'm glad that my site isn't doing the double titles thing anymore.

  13. Emmppp
    Member
    Posted 1 year ago #

    @theddavidsons Thank you !I'll try it again then, because meanwhile I went to All in one SEO, which also works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic