WordPress.org

Ready to get started?Download WordPress

Forums

Problem with Sidebar on Page Template (7 posts)

  1. Laidir
    Member
    Posted 1 year ago #

    Been on this problem for two days now and I just cannot see why my sidebar has jumped to the far right of the page instead of being just to the right of the main content as it is on the index page.

    I'm just wondering if someone can check my css template out with a pair of fresh eyes and tell me if there is anything in it that's possibly throwing it out:

    http://www.thebridesboudoir.com/about/

    I'd be grateful for the help. Thanks in advance.

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You've got a bunch of mark-up (HTML) errors -- particularly the extra, missing or stray tags. One of more of these is causing problems.

    http://codex.wordpress.org/Validating_a_Website

  3. Laidir
    Member
    Posted 1 year ago #

    Hi,

    Thanks, I check the mark up. It throws errors up for line 54. But there is no line 54 in my page.php?

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    The line numbers refer to rendered HTML code -- as that is what the validator validates: That's a relatively minor and harmless error. The duplicate body tags, use of center tags (deprecated) and extra, unclosed, stray, missing tags are more problematic.

    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.thebridesboudoir.com%2Fabout%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

  5. Laidir
    Member
    Posted 1 year ago #

    Hi,

    I know there are validation errors though the pages look fine and all the coding is correct. I can't see anything amiss and the rest of my website is working fine. Those errors are clearly nothing to do with this error. The reason I would say that is:

    If you take a look at my backstage.php page ( a page for all articles categorised as backstage), the custom menu is working on it fine and the sidebar is behaving as it should:

    http://www.thebridesboudoir.com/backstage/

    I duped backstage.php and created a boudoir.php from this template and have changed the template scripting and menu scripting as appropriate.

    http://www.thebridesboudoir.com/boudoir/

    However, the boudoir custom menu is not working and the side bar is out even though I have used the same template and there are no differences in basic structure? Just the menu code differs and the Template name. Instead a random sub menu is being thrown up of pages I don't want to be on the menu bar.

    If someone could help who can look past the validation errors thanks I'd be grateful. If it were the validation errors then the backstage page would not work either in my opinion.

    I've created a category page for both sections and there are links to categories which as yet don't have posts. I've removed or fixed any code I can see out but cannot understand why this is occurring for the odd page on my website when the page is basically the same structure as others.

  6. Laidir
    Member
    Posted 1 year ago #

    I managed to get my pages sorted by duping a copy of my index.php and recreating a page.php from that and taking out elements I dont need, but the category pages I created above... though both exactly the same in structure ... one works and one doesn't. Same problem...sidebar is to the right but also the sub nav menu (second menu) is not being picked up properly even though I have one created in the Menu's section in admin.

  7. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    you cannot ignore two errors of this kind: 'end tag for element "div" which is not open'

    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.thebridesboudoir.com%2Fboudoir%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    and if you assume that these errors are not from the template, because the same template works fine in another occasion, then they might be from the content of the page, or from a plugin.

    that is the validation report of your 'good' page: http://validator.w3.org/check?uri=http%3A%2F%2Fwww.thebridesboudoir.com%2Fbackstage%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    still one one those 'end tag for element "div" which is not open' errors too many.

    there is no way around: http://codex.wordpress.org/Validating_a_Website

    ps:
    are thise two pages actually using the same page template?

    and if so, what is the full code of that template?

Topic Closed

This topic has been closed to new replies.

About this Topic