WordPress.org

Ready to get started?Download WordPress

Forums

Problem with several plugins that all use add_filter() (3 posts)

  1. tripeX
    Member
    Posted 8 years ago #

    Well, its funny, but I couldn't find a solution for this problem.

    I use several plugins, which alteres the content in some way, i.e. wpDefine, SH-Autolink, IMGPop and so on.

    So heres the problem: Some of the plugins do not work with others. i.e. the imgpop plugin do not work together with d13gallery. d13gallery produces thumbs out of a given directoy full of images in a post when there is a d13gallery tag in it. IMGpop works in the other way and produces JavaScript/DOM popups for ever a href with picture tags in it.

    wpDefine for example produces alt text and special css code around given keywords, SH-Autolink replaces several keywords with a given link. Well, both together with the same keyword, won't work.

    Anyone got a solution for this add_filter problem or is it a general WP pluginproblem that has no workaround/fix?

  2. Joshua Sigar
    Member
    Posted 8 years ago #

    Probably just need to set the priority for each plugin appropriately and making sure that the filtered content is returned.

    The plugins' author should know more concrete solution.

  3. tripeX
    Member
    Posted 8 years ago #

    Hm, should have a look into the plugin API and try to fix it myself. Any suggestions are welcome, I'm a real newbie when it comes to do some coding stuff. ^^

Topic Closed

This topic has been closed to new replies.

About this Topic