WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Problem with SEO Title (3 posts)

  1. bobjones
    Member
    Posted 2 years ago #

    I've noticed that if I input an SEO title, Google shows the blog title, followed by SEO title, without a space in between. It looks like this:

    MyBlogPlease enjoy my latest post

    Naturally, I'd like the display to look more like this:

    MyBlog | Please enjoy my latest post

    How can I correct this?

    Thanks.

  2. bobjones
    Member
    Posted 2 years ago #

    To update my post, I'm using this script in header.php:
    <title><?php bloginfo('name'); ?><?php wp_title('|'); ?></title>

    With WordPress SEO active, I see this when I view the page source:

    MyBlogPlease enjoy my latest post

    With WordPress SEO inactive, I see this:

    MyBlog | Please enjoy my latest post

    Clearly, something's up. Is there a setting in WP SEO that will let me display the titles correctly?

  3. bobjones
    Member
    Posted 2 years ago #

    OK, then. This seems to produce the desired result:

    <title><?php bloginfo('name'); ?> | <?php wp_title(''); ?></title>

    Unless Joost has anything to add, this concludes my conversation with myself.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic