WordPress.org

Ready to get started?Download WordPress

Forums

BP Profile Search
[resolved] problem with search in sub site (12 posts)

  1. Flyer29
    Member
    Posted 1 year ago #

    Hi Andrea,

    first of all, thanks for your great plugin and I'm so happy that it's now (almost) working for the newest version of WP and BB.

    I'm using WP 3.4.2 multisite and BP 1.6. The multisite installation is in a sub directory, so something like main/ for the english version and a main/de/ for the german version. I'm using an unique instance of BP for both sites.

    The installation and activation of the plugin works like a charm in the admin menu for multisite, my form is showing wonderfully on the main site. Unfortunately, I only get on the subsite a "search" button without any fields to select. Since the selection of the "selectable" fields is done on the multisite admin level, I have no chance to change anything in the sub site.

    Since I get a "search" button in the form of the sub site, it's telling me the plugin is loading on the subsite but has no field selected for the search, right? How can I set it up, since I don't see setting for BP search profile on the subsite level but only on the multisite level?

    Thanks a lot in advance for your help and again : great work!

    http://wordpress.org/extend/plugins/bp-profile-search/

  2. Andrea Tarantini
    Member
    Plugin Author

    Posted 1 year ago #

    I've only tested this plugin in a multisite installation where BuddyPress is Network Activated. Is your installation different?

  3. Flyer29
    Member
    Posted 1 year ago #

    Nope. As well Buddypress as FB Profile search are network activated. On the multisite admin level, I'm able under user->Profile search to tick the fields that should be searchable. The form then is working on the main site showing all the searchable criteria, on the subsite I only see a "search" button without any criteria to search for displayed.

    I just deinstall, delete and reinstall the plugin and unfortunately it is still not working.

  4. Andrea Tarantini
    Member
    Plugin Author

    Posted 1 year ago #

    Are you using the line

    define( 'BP_ENABLE_MULTIBLOG', true );

    in your wp-config.php?

  5. Flyer29
    Member
    Posted 1 year ago #

    Yes (seems to have been defined as standard).

    Commenting it in or out is having no effect on the problem. In both cases (so with and without the BP_ENABLE_MULTIBLOG) the form is only showing the criteria to search on the main site.

  6. Flyer29
    Member
    Posted 1 year ago #

    Hi Andrea,

    Finally got it!

    The plugin is registering correctly on a multisite environment, but the options are saved locally. So you have no chance to get them on a subsite. For the plugin to work, you have to change the get_option and update_option to get_site_option and update_site_option then it works like a charm ;-)

  7. Andrea Tarantini
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Flyer29,

    Well done! And thank you for sharing the solution, I'll add it to the next plugin version.

  8. blueoceans2002
    Member
    Posted 11 months ago #

    Hello,
    I have made changes as Flyer advised. But still the setting is not shown in subsite & when the plugin is activated within subsite. Any suggestions. Thanks
    Cheers
    Satish

  9. Andrea Tarantini
    Member
    Plugin Author

    Posted 11 months ago #

    Hello Satish,

    I'm afraid you found a plugin bug, I'm trying to fix it soon.

  10. ultimateuser
    Member
    Posted 10 months ago #

    Hi Andrea,

    Any idea on when we can expect the fix?

    Many thanks!

  11. aky007
    Member
    Posted 10 months ago #

    Hi Everyone,

    The profile search in setting still not show up in the subsite.

    Please advice

  12. Andrea Tarantini
    Member
    Plugin Author

    Posted 10 months ago #

    Version 3.5 is out, please give it a try!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic