WordPress.org

Ready to get started?Download WordPress

Forums

Video.js - HTML5 Video Player for WordPress
[resolved] Problem with responsive video - height 30px only (9 posts)

  1. Dirk S
    Member
    Posted 1 year ago #

    I just realized, that responsive video mode doesn't work for me anymore. I set up this Testpage: http://www.webzunder.com/de/videotest/
    The player window has only 30px height, while the width is correctly set.

    What could be the issue? I tried to identify problems with CSS maybe in combination with the Avada template. Do you have an idea what could be the cause of this?

    http://wordpress.org/extend/plugins/videojs-html5-video-player-for-wordpress/

  2. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    What is the exact shortcode you are using? Are you setting a height and width in the shortcode?

  3. Dirk S
    Member
    Posted 1 year ago #

    I used:

    [video mp4="http://www.webzunder.com/de/files/videos/Online-Marketing-Assistent-fuer-KMU.mp4"]

    Should I set a size if its set to responsive anyway?

  4. phlppgrssr
    Member
    Posted 1 year ago #

    Hi,

    same problem here.
    Furthermore, in the post with the video, I get this notice of error (debug is set to "true" in the config):

    Warning: Division by zero in /customers/8/f/1/MYURL/wp-content/plugins/videojs-html5-video-player-for-wordpress/video-js.php on line 160

    .

    If I uncheck any box in the Video.js Settings and try so safe it, i get these error reports:

    Notice: Undefined index: videojs_preload in /customers/8/f/1/MY-URL/wp-content/plugins/videojs-html5-video-player-for-wordpress/admin.php on line 74
    Notice: Undefined index: videojs_autoplay in /customers/8/f/1/MY-URL/wp-content/plugins/videojs-html5-video-player-for-wordpress/admin.php on line 75
    Notice: Undefined index: videojs_reset in /customers/8/f/1/MY-URL/wp-content/plugins/videojs-html5-video-player-for-wordpress/admin.php on line 78 Warning: Cannot modify header information - headers already sent by (output started at /customers/8/f/1/MY-URL/wp-content/plugins/videojs-html5-video-player-for-wordpress/admin.php:74) in /customers/8/f/1/MY-URL/wp-includes/pluggable.php on line 876

    Any ideas?

    Regards

  5. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    Should I set a size if its set to responsive anyway?

    Yes, it still needs a width and height to set the proper ratio for the video. Try adding a height and width and let me know if that helps.

    @phlppgrssr, are you setting a height and width?

  6. phlppgrssr
    Member
    Posted 1 year ago #

    Yes, now I do. I set the multiple aspect ratio. This works for me.

    Example: I want to post a video with the aspect ratio 16:9. So I activate "Responsive video" in the Settings and use this shortcode:

    [video mp4="http://video-js.zencoder.com/oceans-clip.mp4" width="1600" height="900"]

  7. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    Glad to hear that works. I'll make sure to fix this in the next version so that if no value is set it will fallback to a default.

  8. phlppgrssr
    Member
    Posted 1 year ago #

    That'd be nice! It's a great Plugin, thanks for it!

    BTW: I stilll get these error reports when I'm saving the settings, having unchecked a checkbox, such as "Autoplay", "Replay" and "Responsive Video". Is it a problem of my WordPress installation?

  9. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    You probably have debug mode turned on, although I admit that even then it shouldn't be showing you errors.

    The new version defaults to 16:9 if you don't specify a height or width.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic