WordPress.org

Ready to get started?Download WordPress

Forums

problem with putting static info on wp homepage (22 posts)

  1. kwilder
    Member
    Posted 8 years ago #

    http://www.retrieverretreat.com/site (blix theme)

    I eliminated all the code between the content comments on the index.php page. So it looks like this now:

    -------------START--------------------
    <?php get_header(); ?>

    <!-- content ................................. -->
    <div id="content">

    <b>Retriever Retreat</b> is a gathering of women retriever trainers and was designed for them by women retriever trainers. It’s a place where you can relax and have fun while you learn. 
    It’s all-inclusive…  <br><br>
    Just pack up your dog and clothes and take off.  We have everything else taken care of.  No need to drive to the grocery store, try to navigate to an event in the middle of nowhere, or feel like it’s just you and your dog for the weekend. <br><br>
    Retriever Retreat for the ladies is an event like no other.  <br><br>
    It focuses on AKC hunt test events, from junior to master.  It will include group discussion, commentaries from eight-point judges, evaluation of both handler and dog and training advice for problem areas. The event will open with a Thursday night happy hour/meet and greet.  Throughout the event, we will feature one or more keynote speakers at dinner, a special event and lots of great fun in the field.<br><br>
    Lodging is on-site and dog friendly!  All your meals are covered!  Everything in one great location…  Where you can relax and have fun with friends old and new that share your passion for retriever training.<br><br>
    This event is currently slated for June 2006 in South Carolina (tenatively). <br><br>
    Watch our site for more information coming soon!
    </div> <!-- /content -->

    <?php get_sidebar(); ?>

    <?php get_footer(); ?>
    --------------------END-------------------

    But when you look at my page http://www.retrieverretreat.com/site, the php is somehow generating question marks at the end of sentences. I'm sorry I should know how to do this myself, but please let me know how to get rid of them! Thanks!

    -Kristie

  2. vkaryl
    Member
    Posted 8 years ago #

    First thing, try wrapping the content sectors in <p></p> tags instead of using two breaks.

    For some reason, it seems that the charset is not wanting to provide your ellipses, and some of the simple periods are getting whacked too, while others aren't. You'd think it would do the same thing all the time....

    I don't think the php is what's doing this. More likely to be a mismatch between charsets. In your admin section, Options/Reading, check to see what charset is listed in the box.

    And are you using the fancy rich editor to compose?

  3. vkaryl
    Member
    Posted 8 years ago #

    Hmmm. Just read this topic:

    http://wordpress.org/support/topic/25402?replies=6 - I wonder if maybe you should try changing the charset to ISO-8859-1?

  4. kwilder
    Member
    Posted 8 years ago #

    Will try the suggestions. I had it set up with 's and it did the same thing. Very strange... Then removed p's figuring <br>'s were as simple as I could get. ;)

    So far so good with this script. It's wonderful.

    -K

  5. kwilder
    Member
    Posted 8 years ago #

    ps -- composing in textpad and uploading via ftp

  6. kwilder
    Member
    Posted 8 years ago #

    You guys rock! I've never had everything work so smoothly when I needed help on dumb stuff like this. I changed the charset and it's fine. Thanks!

  7. vkaryl
    Member
    Posted 8 years ago #

    Well, I'm fair useless with blix, it's a PITA theme (almost as bad as kubrick), and if in fact this is theme-based wonkiness and the change of charset doesn't fix it, I'm not sure what else to offer....

  8. vkaryl
    Member
    Posted 8 years ago #

    Oh good! I'm so glad! You posted as I did....

  9. kwilder
    Member
    Posted 8 years ago #

    well, back to this again... so i changed the charset and it fixed the homepage. I hadn't looked at it again til i started working on it today. It had taken the odd characters out of the homepage... but then ADDED characters to the normal blog entries! go figure. I tried all different charsets and couldn't get anything to work. Remember, this is blix and you said it was screwy...

    Take a look at http://www.retrieverretreat.com/site (and it's the static text right there in the main content area before the most recent entries below it). I tried fudging around with it with what little I know of php, but couldn't get anything to work. I can't come up with any good reason for the "?s" to be where they are??? Makes no sense. Like they're just randomly thrown in there.

    Is there any way to otherwise insert the text there? I'm about to give up and make it a graphic and call it in that way...

    Thanks in advance.

    -K

  10. vkaryl
    Member
    Posted 8 years ago #

    Well, yeah.... There is a way, if you (figuratively) don't mind getting your hands dirty....

    You have to be able to access your database using phpmyadmin. If that's possible on your host, email me at vkaryl *at* bytehaven *dot* com and I'll walk you through some detailed tweaking the database stuff.

    Before we go into that sort of stuff though: try writing the text in a plain vanilla text editor like notepad2 from http://flos-freeware.ch/, then paste into the edit window - with the wysiwyg disabled please!

  11. kwilder
    Member
    Posted 8 years ago #

    i do have access to the db if needed.

    i am working directly on the index file in textpad (which i've heard is a really good, safe editor). does that count? I'm not editing the files online. i'm editing and then uploading. I tried following instructions to change permissions so i can edit online, but it didn't seem to work. Let me know what you prefer for me to do. Won't email til you tell me to. THANK YOU!!!!

    ps -- just checked to make sure my ftp connection was on ascii and it was on binary (not sure why). re-uploaded in ascii and no difference.

    EDITED: I was just able to get permissions working. will try option 1 and then email if it doesn't work.

  12. vkaryl
    Member
    Posted 8 years ago #

    Yup. Just email me at this point, and we'll dig around some - it's late here for me, but go ahead and mail me when you need to, I'll start on a workaround tomorrow....

  13. kwilder
    Member
    Posted 8 years ago #

    That did it! I changed permissions of template files to 666. is that ok??? That's what seemed to work. question marks were there when i access file that way and i just removed them. all is well. let me know if those permissions are ok or if they should be something else.

  14. vkaryl
    Member
    Posted 8 years ago #

    Technically: 666 should be okay though it's not preferred. Is this just theme files you have set 666, or is the whole wp-content folder and all the theme folders set 666?

    If the whole wp-content folder, you might want to rethink. Just theme folders shouldn't be too big a problem, though truth to say, I run my whole install on every blog I have (12 at last count....) with every folder at 755 and every file at 644, and have no problems at all.

    So it's a little worrying....

  15. kwilder
    Member
    Posted 8 years ago #

    i just don't know what the heck it means... :) I have JUST the files under the blix folder set at that. Will 644 still work?

    -K

  16. vkaryl
    Member
    Posted 8 years ago #

    It might. You can try it. If it doesn't work, you can put it back.

    I don't know what the heck it means either - honestly I can't really conceive of a scenario in which file permissions have anything to do with extraneous ? in your posts....

  17. kwilder
    Member
    Posted 8 years ago #

    They weren't editable at 644... so they're at 666 and if some hacker wants to be a jerk so be it..

  18. vkaryl
    Member
    Posted 8 years ago #

    Make database backups on a regular basis. Safety in numbers (I'm the undisputed queen of redundant backups - I have some stuff back to 1984, first computer....)

  19. kwilder
    Member
    Posted 8 years ago #

    lol, why don't you go ahead and restore that 1984 backup? THANKS!!

  20. vkaryl
    Member
    Posted 8 years ago #

    Hey, I actually accessed that disk not too long ago, looking for a particular graphic. Guess what? I found it. And while I was there, I wrote all that stuff to cd.... (Was a copy of a 5.25 floppy to a 3.5 floppy - didn't lose a thing in the intervening years either! *laughing*)

    Best of luck to you, kiss the doggies for me! Other problems, either post back or email me.

  21. kwilder
    Member
    Posted 8 years ago #

    on more useless post -- i was watching wargames over the weekend (matthew broderick -- wow, that movie is 23 years old!!!) and he pulled out the 5.25 floppy and I was like "wow, i forgot how big those things were!"

  22. vkaryl
    Member
    Posted 8 years ago #

    *snicker* Forgot that one.... thanks for the memory!

Topic Closed

This topic has been closed to new replies.

About this Topic