WordPress.org

Ready to get started?Download WordPress

Forums

Problem with publishing site - URGENT - please help (9 posts)

  1. johndove523
    Member
    Posted 2 years ago #

    I'm trying to publish my WP site to the root from a /wordpress/ subdirectory using these instructions:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install"

    I followed the instructions TO. THE. LETTER. (and I do have an htaccess file, btw, which I made no changes to. It appears a web.config file referred to in step 4 does not apply to me.)

    On step 7, when I try to log in, I DO get the login screen as it suggests: "It should still be http://example.com/wordpress/wp-admin/"

    But then I get the error: "The page isn't redirecting properly"

    Can anyone help me out?

    Thank you.

  2. johndove523
    Member
    Posted 2 years ago #

    When I try and log in at http://caspca.org/wordpress/wp-admin/ it re-directs to this: http://caspca.org/wp-login.php?redirect_to=http%3A%2F%2Fcaspca.org%2Fwordpress%2Fwp-admin%2F&reauth=1

    (if that provides any clues that lead to the re-direct error)

  3. cjc1867
    Member
    Posted 2 years ago #

    Can you put a link on here to your site?

  4. johndove523
    Member
    Posted 2 years ago #

    CJC, just did.

  5. johndove523
    Member
    Posted 2 years ago #

    correction on my last response - when I go to: http://caspca.org/wordpress/wp-login.php - I do get the login screen.

  6. cjc1867
    Member
    Posted 2 years ago #

    We crossed post at the same time.

    I have just got to your log in screen from here Login

    Does that link get you back in?
    Did you copy your .htacess file to the root and saved your permalinks before? if not try and save them again if you can get back in with my link above.

  7. johndove523
    Member
    Posted 2 years ago #

    I get the login screen, but then the error (same as before): "The page isn't redirecting properly"

    I did not change my permalinks, as that is the last step in the instructions which I haven't had the access to get to yet. Seems like they would have put that step before if required.

  8. johndove523
    Member
    Posted 2 years ago #

    Should I put everything back like it was PLUS change my permalinks along with the site address in step 2, and try repeating the instructions?

  9. johndove523
    Member
    Posted 2 years ago #

    I'm out of time for today. I'll have to re-publish the old site and try a different approach tomorrow. These instructions:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    are clearly flawed, as I did exactly - precisely - what it said to do.

    Thanks for the help, cjc.

Topic Closed

This topic has been closed to new replies.

About this Topic