WordPress.org

Ready to get started?Download WordPress

Forums

Problem with Permalinks and 404 Page not found error messege (3 posts)

  1. universaltruth
    Member
    Posted 4 years ago #

    I am able to use permalinks by using the following Custom Structure field on the Permalink settings page.

    /index.php/%year%/%monthnum%/%day%/%postname%/

    So that it appears like this:

    http://www.mysite.com/index.php/2009/05/25/sample-post/

    However I tried to shorten the URL so that it does not contain the /index.php

    I read that this is possible by removing /index.php from the Custom Structure field like so

    /%year%/%monthnum%/%day%/%postname%/

    So that I get:

    http://www.mysite.com/2009/05/25/sample-post/

    However I now get the 404 Page not found error messages when I click on new pages or posts or click on old links.

    Is this a problem with my shared hosting server or is this just not possible to do. I have the latest version of WordPress installed. I have not installed any pluggins accept the SEO pluggin.

    I am using the following:

    PHP version 5.2.9
    MySQL client version: 5.0.22
    Website: http://www.earnmoneyonlinetools.com/
    Web Hosting: IX Webhosting

    Thanks,

  2. iridiax
    Member
    Posted 4 years ago #

  3. universaltruth
    Member
    Posted 4 years ago #

    Thanks for your response. If I transfer my domain to a Linux server this supports the mod_rewrite. I am currently using windows.

    Would i need to change any code in any WordPress files manually or are all the correct settings for "pretty" Permalinks set by default?
    So I just need to alter the Custom structure on the permalinks page in admin.

Topic Closed

This topic has been closed to new replies.

About this Topic