WordPress.org

Ready to get started?Download WordPress

Forums

Problem with Permalinks (7 posts)

  1. lukadium
    Member
    Posted 6 years ago #

    Hi, I want to use pretty permalinks for my blog,like this structure:
    http://www.itholics.com/author/imilad/
    but when it seems that I have to use this structure instead:
    http://www.itholics.com/index.php/author/imilad/

    How can I remove the "index.php"?
    I have read many support topics about .htaccess and mod_rewite but I still could not have the issue fixed,
    Although I have set the chmod of .htaccess to 777 , when I update my permalinks it wordpress does not write anything in the .htaccess but it shows the success message!

    I will be thankful if u help me with the issue.

    My apache version is: 1.3.37 (Unix)

  2. Chris_K
    Member
    Posted 6 years ago #

    For reference, see the Permalinks page.

    A) Does your host support mod_rewrite?
    A.2) If so, is AllowOverrides properly configured?

    B) Set your .htaccess to be read only. Visit Options -> Permalinks. At the bottom of the page, WP should tell you what to manually add (since it can't write to .htaccess). Does it?

  3. lukadium
    Member
    Posted 6 years ago #

    Thanx HandySolo,
    I have already read the Permalinks page,
    As it takes a long time for me to find out whether my host supports mod_rewrite I did the what u said in part B,but to my surprise wp did not show any errors while updating permalinks neither did it show me proper codes to be put in .htaccess and successfully updated, but the problem still exists.

    By the way is there any chance I would find whether my host supports mod_rewrite by myself without contacting my host support?

    Thanx a Lot,Good Luck

  4. Chris_K
    Member
    Posted 6 years ago #

    Create a file named test.php with the following one line in it:

    <?php phpinfo() ?>

    Upload it, point your browser at it. Search the results for mod_rewrite to see if it's loaded.

    What that won't tell you, however, is if AllowOverrides are properly set ("part 2" of the mod_rewrite thing).

  5. Chris_K
    Member
    Posted 6 years ago #

    oh - and delete test.php when done, you don't want that laying around!

  6. lukadium
    Member
    Posted 6 years ago #

    Thanx, I did it and the mod_rewrite did not show up!
    So it seems I'm finished with pretty permalinks :(

  7. Chris_K
    Member
    Posted 6 years ago #

    Yup, that relegates you to "almost pretty" until your host fixes you up.

Topic Closed

This topic has been closed to new replies.

About this Topic