WordPress.org

Ready to get started?Download WordPress

Forums

Problem with permalink (3 posts)

  1. lpleva1
    Member
    Posted 1 year ago #

    Hello,

    For reference, here is my website:

    http://moneythink.org/

    If you hover your cursor over the "About" menu label and then click on "Board of Advisers", you'll see the page load with the following URL:

    http://moneythink.org/advisers/

    To better reflect the site hierarchy, I'd like the URL to be:

    http://moneythink.org/about/advisers/

    Problem is, whenever I try to add the "/about/" into the URL field when editing the page, it just converts to "http://moneythink.org/aboutadvisers/

    As you might notice, there is no "About" page. It's actually just a # link with CSS to disable the cursor effect, since I wanted the "About" to be a label, not a clickable page. Because of this setup, however, I cannot make the Board of Advisors page a child of "About", which would add the "/about/" into the URL.

    Any ideas on how to fix this issue?

  2. Lindy Norris
    Member
    Posted 1 year ago #

    I don't think there is any elegant way to get around the WordPress hierarchy. I would suggest you actually create a page called About and then make Advisers a child of About. In your navigation you can still keep About as just a label with your # link.

    If you are worried about the URL http://moneythink.org/about/ getting indexed or users landing on it you could 301 redirect it to http://moneythink.org/about/advisers/ just make sure you don't get yourself caught in any redirect loops.

    Hope this helps, and if you find another solution I'd love to hear it!

  3. ricardusexa
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic